Why is there a random sphere in the middle of my scene when rendering a video through Matinee?

I am having an issue when rendering out a video through Matinee. For some reason there is a random sphere object that appears at the world center axis, but only when rendering a video. It does not appear in the editor window, nor does it show up in the Matinee video.

Here is a shot of what how my render looks…

And here are shots of my level BluePrint as well as my Matinee…

1 Like

I figured it out lol I needed to add a player start to the scene in order to remove the random sphere…

1 Like

I’m having the same problem, so I’m wondering what do you do to “add a player start to the scene”?

Top left tab for “Modes” in the editor. Search for Player Start and drag into your scene.

Same thing happened to me. However after placing a player start in the scene, it still shows up. Any more solutions to this issue?

I ended up moving the play start under my scene so the sphere wouldnt show up

This sphere represents the player and will appear wherever the player is when the matinee is triggered. You can hide the player in the cinematic by ticking “Hide Actor” in the details panel of the Matinee actor.

thanks @RobbZ3D

Thanks! That helped even inside unreal sequencer render. Do you know why that happened?

it’s ridiculous but that’s what works, it worked for me

Years later and this issue persists, but the workaround is straightforward: In your render queue, make sure you have a Game Mode Overrides setting added and enabled. When you override the game mode to a Cinematic render mode, the player position sphere is not rendered.

1 Like