Why is the pivot shifted a little bit after export from PhysX Lab

I have a .fbx mesh that im trying to convert to an .apb destructible mesh with PhysX Lab.
After importing my mesh into PhysX Lab, the pivot is shifted to center (not exact center) in UE4.

When I import .fbx mesh from Maya into UE4, the pivot position hasn’t changed in UE4.

Hi Coconutmacaroon,

Using your description I tried to reproduce this with a simple box asset that has the pivot at the center of the base. I’m not seeing the same results you’ve described. I used my older version of PhysXlab 1.3 and the latest version of 1.3.3 (11/2015) that was available in their downloads section.

Have you tried using the PhysxLab DCC plugin for Maya to see if that solves your issue? Currently I’m using 3Ds Max, but if you wanted to upload a test FBX that reproduces this I could have a look to see if I can see any inconsistencies between current and previous version of UE4 to rule out that as a possibility. If it’s something you feel is wrong wtih PhysXLab you’ll want to report this on their forums.

Thank you!


Thank you very much for your kind reply.

I used Unreal Engine 4.9.2 with PhyxsSlab 1.3(Beta) and 1.3.3.

I’ve installed the PhysX maya 2014 plug-in, but I couldn’t find any options for fracturing object.
There is other options for Cloth but there aren’t any options for Destruction.

It seems like authoring applications are PhysX plug-in for 3ds MAX and PhysXLab.

I uploaded .fbx and .apb data.
floor_F2.apb is exported from floor_F.fbx via PhysXLab.
Please take a look at those data when you get a chance.

Thank you in advance.
alt text
link text

Ok, I think I’ve got a workaround figured out for you and can potentially explain what I’m seeing.

With PhysXLab it seems that when the mesh is imported it’s setting the pivot to the center of the mesh. I didn’t see this in my original test because I used a simple box asset with the pivot already centered out to the mesh. I typically don’t use offset pivots for assets when I create them so this was out of my normal workflow, which explains that issue.

This should be fairly similar to Maya with the DCC plugin, but I cannot 100% confirm since I do not have Maya on my computer, but here is my workflow for 3Ds Max with the plugin and using PhysXlabs to get a proper pivot offset for an .apb destrucitble asset type.


  • Create your asset
  • Click the “beaker” physxlab icon in the dcc plugin toolbar


  • This will turn the mesh into a Destruction mesh, in the details panel if you expand the drop down you should see the option for fracture. Select this and choose fracture in the settings. This is what it looks like in Max, not exactly sure about Maya, but if you’re having problems finding this let me know and I can test on a colleagues machine with Maya.

  • Once you click the Fracture button it will open PhysXLabs and you can fracture and setup your mesh here. You should see something like this to indicate that it’s tied to Max/Maya.

  • Once you’ve finished your using PhysXLab you can click the Save button and it will transfer back to Max/Maya. You will notice the pivot has shifted to be centered to the mesh now.
  • At this point you can re-adjust the pivot to where you would like it or when you export the asset the world origin will be used as the pivot since UE4 uses this rather than pivots specific to the mesh when they are imported.
  • When you export from Max/Maya use the file type “PhysX and APEX”. This will open the dialog box where you can export your PhysX assets. Make sure that you’ve enabled the option for Export Destruction Assets otherwise they will not be exported. This option was not enabled by default on my machine.


Now when you import into UE4 the pivot should be in the correct location.

Hi Tim,
Thank you very much for answering and uploading detailed steps for 3ds Max.

I am wondering Maya DCC plug-in doesn’t have PhysXLab module.
I will ask about this on NVIDIA’s site.

I installed Physx DCC plug-ins for Maya(ver 3.3).

The tool bar and menu is a little bit different from 3ds Max.
Thank you for uploading those screen shots, it is really helpful to understand.
Tools for 3ds Max looks like more advanced compared to Maya.
And the interface of 3ds Max plug-in is same as stand alone PhysXLab.

Here is Maya’s tool bar, it doesn’t have PhysXLab for destruction.

Thank you for considering about this problem.
I installed 3ds Max today.

Lookign at this a bit more, from what I see it is suggested that it works with Maya the same, but I couldn’t find a way. I’m glad you have access to 3Ds Max to make it a little easier in this regard for you.