Why is the mesh simplified when importing?

Recently, the number of triangles in my models began to decrease when imported into the engine.
The screenshots show that the original mesh had chamfers, but in the mesh editor almost all the chamfers disappeared and the mesh looks ugly.
It looks like LOD, but I have not used LOD for this model. Previously, everything was fine, I made a lot of models, both simple and complex.
I did not update the version of the engine. I also tried to reset the import settings to the default. I use Blender and tried all smoothing settings.
The temporary solution that I found is the use of Subdivision Surface, but in any case, the model is simplified when importing.
Does anyone have any idea why this is happening?

Maybe you used modifiers to get that mesh? In that case make sure you apply your modifiers, either manually or by ticking the apply modifiers option when you’re exporting the mesh.