Why is the Height-blended Landscape material showing holes even with an alpha-blended layer?

Hi There. I have been beating my head against a landscape issue for a few days now. Basically I have a landscape, it has 4 layers, all layers aside from one are set to LB_heighblend. One layer is set to LB_Alphablend, as recommended by this [Documentation here][1]. They show my issue, say to set a layer to alphablend, which I do, but I still have holes in my terrain.

Th weights for each layer are imported from a splatmap from World Machine. All the layers values added together equals 1, across the whole terrain, so there is no place that my weights should be 0, which as I understand is the cause of holes when you see them.

I’ve attached a picture of my material tree, and what I’m seeing. I’d love it if someone could help me.

Also, to further illustrate, click [HERE][2] to see a video I made explaining my full setup.

Also, in case anyone wonders, If I set all layers to alphablend, I get no holes, but that is not a solution.

[FullView][4] -
In this image, the bottom stone layer is not using a heightmap as you can see. That is the alphablend layer.

[FullView][6]

Black spots are caused by zeros. According to Landscape Material Layer Blending in Unreal Engine | Unreal Engine Documentation just make one layer an alpha blend instead of weight so you can nvr have a zero

The solution could be to use a landscapelayerweight node instead of the layerblend node.

That too. I think that had me screwed up before

This is NOT the answer to my problem. Why was someone else able to mark it as the answer? I state clearly in my first post that I have done this and that this is the result even after setting the one layer as an alpha blend.

Please fully read the Original post.

This is the answer. Ur exact problem is written in the ue4 docs. Just confirm your set up is correct. Is your first layer the alpha? How did you save your layer infos?

LandscapeLayerWeight doesnt let you do heightmap blending does it? If so I cant figure out how. Note when I say Heightmap, I am talking this sort of blending, not an actual Terrain heightmap: https://docs.unrealengine.com/latest/FRA/Engine/Landscape/Materials/index.html#landscapelayerblendnode (scroll down a couple lines to see) To my knowledge LandscapeLayerWeight node cant do that.

I did not change my nodes from what is shown in the picture. You can see the bottom layer does not have a heightmap plugged in, that is the layer that is marked as LB_AlphaBlend.

The Layer infos were created as normal in the terrain tools, I chose WeightBlended for all of them. Is this what you mean?

I belive your bottom payer is the first one listed in the node not the last one

So I should reverse my layers and have the top be Stone, and have that one marked as alphablend? Thanks for the help by the way.

Ya id try that. Thats how the setup is in the ue4 docs

Ok, that didnt fix it. The result is still the same. Is there a limit to how many layers can be contributing to an area? the areas I see the issue are only in places where there’s 3+ layers contributing.

Though, now if I paint very very lightly over everything with the alphablended layer, it appears to be filling the holes properly, though it is slightly changing the appearance. But I can live with this.

Ya the weight total cant equal zero. When the brush is blending i think its subtracting from surrounding layers possibly creating a zero. Try saving ur alpha blend as a non weighted layer. And i think its a 16 texture total for the whole landscape.

I’ve run head first into this problem too, and I’ve been unable to find a solution. Unless I set all of my layers to use alpha blending, then I get giant holes all over my landscape.

I am also having this problem. Judging from the amount of people this is a serious issue that needs to be addressed, especially now that shared texture samplers are allowing us to have so many layers.

Epic, if you guys can’t fix it due to priorities can you at least point us to what the fix IS so our programmers can quickly rectify this ongoing bug?

Thanks!

So Ive tried everything in the docs, and my material is full of the aformentioned black holes, has anyone fixed this?

Still having this problem as well. Can we get an answer to this?