Why is Sequencer Bake To Animation not accurate?

I tend to use a custom rig for my characters, but for a project I’m currently working on I figured it would save time to just use the rig provided in engine with MetaHumans rather than set up a control rig manually.

However I’ve run into a strange issue, for some reason the results I get after I pose and bake an animation through sequencer is nowhere near what it looks like in sequencer. I get weird distortions and bends on bones that are not visible in the sequencer asset. I’ve tried everything I could think of to alleviate the issue but to no avail.

Searching online didn’t yield much success, I only found one person who seemingly ran across the same issue and they didn’t receive any answers. Why aren't animations created from control rig exact?

I’m using 4.26. Any help would be greatly appreciated. I can’t imagine this behavior is intended right?

As a follow up to this, I went ahead and updated to 4.27 to see if it was fixed there but I’m still getting the same result. Going to probably end up having to create a control rig in Maya, but hopefully someone sees this and can possibly look into what’s causing it?