Download

Why is my Widget Component not Rendering?

I’m wondering why my world-space widget component is not rendering during play on actors spawned during runtime.

If I depossess and wiggle the camera, they pop into existence and stay rendered when I repossess.

If I move my camera in so close it clips the static mesh of the actor of which the widget is a component, it renders during play as it should.

Any advice on this issue would be appreciated.

Cheers.

I’ve discovered that the determining factor of whether or not the widget component renders is the Resolution Scale value in the scalability settings.

Does anyone know of a way to force a widget component to render regardless of the resolution scale?

Even with this value at 100%, if I make the game window small enough, the widget components fail to render.

The widget components will render if I enlarge the game window enough while it’s running.

Cheers.

perhaps it clips it thinking it is outside the viewport

@BCETracks, thanks for your reply.

I’ve tried moving the camera in and out by thousands of units but the issue persists. It also occurs equally with perspective and orthographic cameras.

I’ve also tried adjusting the Near Clip Plane value in the project settings but again with no luck.

As well, I’ve worked out that this only occurs on actors spawned during runtime. If an actor is placed in the editor, its widget component renders normally but if it’s spawned, it only renders sometimes or needs the game window to be resized during play before it renders.

I am having the exact same issue where Widget Components in spawned Actors do not appear until the camera is moved to fully frame the spawned Actor. I am using an Orthographic Camera, and the Widget Component in spawned Actors are not rendered at run-time until the Camera is moved to a position where the spawned Actor is in the middle half of the Viewport, at which point the Widget Component suddenly appears and will stay visible regardless of the Camera’s position/movement.

I am using UE 4.22.3.

I was contacted by Epic after I reported this as a bug. They explained the way to fix the issue is to check “Tick when Offscreen” on the widget component.

Cheers.

**MC1RScorpion, **after some experimentation, it seems like Widget Components are only rendered after its Bounds and/or Transform point is within the Camera’s field of view, and it turned out that my Widget Component’s transform point was offset way above the visible canvas objects within the referenced Widget Blueprint, so I was able to fix the issue by adjusting my Widget BP and moving the Widget Component within my Actor so that it was closer to the rest of the Actor’s visible components.

Alternatively, setting the “Use Attach Parent Bound” value to **true **in the Widget Component’s Rendering (Advanced) Details seems to work too, although the Widget Component will disappear if the Actor’s other components are out of view.

I hope this helps.

Oh, I just saw that your replied while I was typing my reply. Of course, “Tick when Offscreen” is 100% the solution. Thanks!