Why is my variable not showing up in my blueprint?

I created a Variable in my blueprint called IsDoorLocked. It works fine, but is not showing up in the left-hand pane that shows what variables, components, etc are in my blueprint. This variable is set to publicly editable, and is the only publicly editable variable. Am I missing something, or is this a bug?

You can see in the image that the variable is being used in the blueprint, it works fine, but isn’t in the left-hand pane.

Problem solved: I discovered that I created a category called “Door Properties” where the variable is under, it was hidden there (you can see it in the screenshot).

However, it would be SUPER helpful is when I searched for variables, if double-clicking on it in the search results revealed it in the left hand pane by expanding the category it’s in and highlighting it.

Mark it as solved :wink:

As zamy said once someone (even yourself) found a solution to the question please use the small icon just below the voting arrows to mark it as solved so everyone can see that there isn’t any more help needed.

I’ll do that for now :wink:


Will do in the future. Thanks!