Why is my spotlight bounding box not visible?

This is a hard problem to describe in a question. I’m trying to create some spotlights in my scene following a tutorial, but when the speaker creates spotlights he gets a cone shape that indicates the extent of the spotlight shape and I don’t. I have tried a lot of different settings and options to turn this thing on but I can’t find anything that will affect it. You can see the cone made of light blue lines in the attached image.


Can you show how it looks like on you end?

I can see the light effect but not that bounding box. I’ve also noted that most of the bounding boxes for light and reflection effects are not visible currently, nor are the light icons that I used to see.

Perhaps you hid the light by accident:


Can you double check where the red dot is - the eye icon.

No the light is visible in mine, the eye is turned on. I am unable to see the bounding box with the eye on. I also can’t see any of the light icons that appear in the tutorial and which used to be visible in my scene.

His light looks more evident because it’s closer to the wall, but my light is on.

this could seem obvious, but if you are new in the engine Maybe you just Hided the Gizmos per accident. Try selecting your light in the scene and then pressing “G” on your KeyBoard.

1 Like

I, too, feel it’s something small and elusive. Could be it, good suggestion.

Anyone have a different solution? I have the same problem and it unfortunately isn’t game visibility related (Gkey)

It may be that you have the Show Flag for Light Radius disabled (Show->Advanced->Light Radius) or (Alt + R)


This was the thing for me. I accidentally hit Alt while holding R. Thanks