Why is my SkeletalMesh export missing bones?


I am starting to play around with character modeling.

However, I noticed that you can’t export a skeleton file. You only get a text file with the file name. You can export and re-import the default character as FBX, but bones are lost in the process (probably because they don’t exist in the character file, only in the skeleton).

UDK used to offer a sample skeleton as a maya or 3ds file, so that users could base assets on this and reuse the current animations. Would this be possible ? Whatever the file format, though a simple FBX would be fine I guess.

Thanks !


When you say "export and re-import the default character’, are you exporting the skeletal mesh asset? You should be able to export that as an .fbx with no problems. I just tested it using the HeroTPP skeletal mesh from the Third Person Template and it worked fine. The only issue is when you import the fbx that it generates to Max or Maya (or any other program I suppose) the joint hierarchy and the mesh are both children of a new node named after the original asset (HeroTPP, in this case). You would want to unparent those and just delete that new node. The Root bone of your joint hierarchy shouldn’t be a child of anything, and your mesh doesn’t need to be included in your joint hierarchy either (since it is skin weighted to the joints).


Well this same asset exports well, yes, but I don’t have any bones in the resulting file. Since I am using Blender this may be the problem, the FBX import is not perfect, but I wanted to check first if this is supposed to happen…

Hey, I just tried to convert the FBX to Collada using FBX Converter, then import that in Blender. It works. So this is just the Blender FBX import.

Thanks a lot !