Download

Why is my skeletal mesh faceted?

I finished a model in Maya and imported it to UE4. Everything was fine and the model looks great.

I than rigged it and re imported it as a skeletal mesh and it became faceted and not as smooth as the original static mesh.

Can anyone help me with this?

(See how smooth the wheel is on the right robot compared to the left one. its exactly the same model)

48cef6a9638db3df0ce6450e171069ad8c89af16.jpeg

Thank you,

Nadav Hekselman

Have you experimented with the different options for calculation of normals?

Im not sure what you mean. Is there a way to do that in UE4? Can you please show me an example ?

Yes in UE4. it would be in the mesh import settings. UE4 offers to calculate the normals for you, or import from the FBX file. You may have to expand the sections (there are down arrows) to see this option.

I’ve already answered this one on AnswerHub but don’t mind duplicating it here - make sure you are using soft edges in Maya.

Yes! It worked! thank you!