Why is my mesh falling appart

WHen i simulate my skeletal mesh, its falling appart what have i done wrong?

I think you need to turn off physics for the various meshes.

Its just 1 mesh imported from blender

Hey, @wiilliamx! Have you tried editing the physics asset constraints on your mesh? Also, have you double checked and made sure your bones/armatures are properly placed and attached in Blender

Hello unreal just auto made bones from the origin of each mesh part in the model…

I think I see what you need @wiilliamx . What I believe you are trying to do is make sure the wheels don’t turn out of the sockets and neither does the bike handle, right? Try following this tutorial (pay attention to the knees for example) and use this tip to adjust the small details and I think that should get you set so your parts do not roll out of place.

Hi all,

I wanted to chime in with another video link.

It looks like you’re trying to create a wheeled vehicle, if you’re using UE5 be sure to consider ‘the new hotness’ of chaos vehicles.

This video is cool because it takes you through the setup process, there is a bit at the end that addresses how to setup motorcycles.

1 Like

Hello again
So i fixed my issue with my mesh parts by playing with the angular and linear limits

but i have another issue, i have followed to unreal engine youtube turorial on how to make wheeled vehicle. But when i play game the wheels doesnt apply acceleration and fall through the ground.

Hey @wiilliamx!

Great to see you cleared the hurdle! First and foremost, what does your vehicle blueprint look like? Are your wheel blueprints set up as well?

I see you are using UE 5. There is a new tutorial for Chaos Vehicles (the current physics system). Here is the link to that video just in case:

Driving Around: Exploring Chaos Vehicles | Feature Highlight | State of Unreal 2022

Any more details you can provide about what you currently have will definitely help crack your case!

Hello so my vehicle is making accenration just on the wrong axis lol, how can i change this

Generally the standard ‘forward’ direction is in the positive direction down the X axis. So I’d check to see what axis your bike is aligned on. From your previous screenshot it looks like your alignment is correct.

You can always do File->Zip Project to post a copy of the project files. (It does not include engine assets, so usually the .zip is very small!)

Hello again
I made a new project to zip. The bike falls through the ground an i dont know why, i would appreciate any advice on how to fix
MyProject5.zip (3.5 MB)


For anyone opening the project, the files are located in the ‘Developers Folder’ which may be hidden. - There is an option to show the developers folder in content browser settings.

(the question mark was next to simulate physics, because after dragging the skeletal mesh into the world and simulating physics nothing happened)

I was able to prevent the bike from falling through the ground by changing the ‘Physics Type’ on the wheel from “Kinematic” to “Default” and ‘Collision Response’ from “Disabled” to “Enabled” - But I haven’t had a chance to run through that entire tutorial video I linked previously, so I’ll need to double check that for any conflicting instructions.

I took a look at the video, Kinematic and “Disabled” collision response is correct.

I found that playing with the wheel radius values in the ChaosVehicleWheel classes helped with the wheels falling through the ground.

I did notice that your bike is very small ( 1 meter x 1/2 meter) part of me wonders if Chaos expects ‘real world’ values somehow. (Although driving tiny vehicles around should also be supported!)

So i think i found a major problem. In the yt tutorial he said the bone scaling should be set to 1, but they were set to different values. Is this a problem that need to be fixed withing blender, where i made the mesh i suppose.

Driving Around: Exploring Chaos Vehicles | Feature Highlight | State of Unreal 2022 - YouTube timestan video

So i seem to have fixed my issues, the main issue was that my export mesh from blender didnt have rotation and scale applied, so the bones were all messed up. By tweaking the center of mass its also not falling over anymore but still wobbly movement.
Thanks for replies


1 Like