Why is my material opacity turning black in game, but preview looks perfect

I’m working on what should have been a simple, stylized particle effect similar to how the Jetson’s flying vehicles emit “anti-gravity hoops” that disappear a short distance after being emitted.

I got the effect looking exactly how I want in Niagara, but as soon as I try to use the emitter in the world the hoops turn black instead of transparent. I’m just using it in a default template map, no custom PP or other effects applied to camera.

It’s a very simple, relatively cheap material. A Mask + Dithering option works, but doesn’t get the look I need. What am I doing wrong here?

If I set the opacity manually to 0, I still get the black texture in the world and the Niagara preview shows invisible hoops as expected.

Engine version 4.26 in case that matters. Any guidance would be fantastic.

I’m sorry if it’s too irrelevant to your question. But instead of using the alpha channel of your particle color to fade out the particle. Can’t you just dial the value of your particle color down to black?

Since additive blend mode renders the blacks as transparent it could work.

Material Blend Modes | Unreal Engine Documentation

That’s a good idea. I gave it a shot but to no avail. I even made a quick reproduction of the texture in the example and here’s what I got…

Game world with several objects utilizing this material

Niagara preview

I tried it on both Unreal Engine 4.27 and 5. It worked without a problem.
My setup on both of them was the same:

I also applied my materials as material override in the mesh renderer. Did you applied it to the mesh directly? It shouldn’t have an affect on it but, Who knows :smiley:

If applying the material as override won’t work, you can try to migrate your project to 4.27. Or catch up with 5 and see if it works on those versions…

1 Like

Thank you for your time on this. I found the problem. For anyone else that ends up here, the material setting Usage → Used with Editor Compositing was the problem. Not sure how it got enabled, but weirder things have happened.

1 Like