Why is my Light Propagation Volumes causing crash with translucent material in a multi-material objects?


I know LPV is still in development but i ran into an issue that is not mentioned in the documentation so i thought it may be helpful to know.

Basically, when you activate LPV and there is an object in the level with multiple material ID’s, and you plug a translucent or additive material into one of the slots the editor crashes.

Repro steps:

  1. Enable LPV
  2. Bring an object with more than one material ID’s into the map
  3. Insert any translucent or additive material in any of the slots
  4. Crash!

The workaround is to disable Affect Dynamic Indirect Lighting in the object’s properties, but as you can imagine it doesnt give the desired effect.

Let me know if more information is needed.


For me the editor crashes only if an actor with such material is selected with LPV enabled.

A workaround I’ve been using is setting the view mode to unlit (Lit=>Unlit on the third dropdown from left to right at the top of the viewport) before selecting the actor or material and making whatever changes I need. After that deselect the object and set the view mode to lit once again (Unlit => Lit).
Just be careful not to accidentally click on the actor after that, or else the editor will crash.

For your particular case (assuming the issue is the same):

  1. Enable LPV
  2. Bring an object with more than one material ID’s into the map
  3. Set view mode to Unlit
  4. Insert any translucent or additive material in any of the slots
  5. Deselect the actor
  6. Set view mode to Lit

It seems to be the same issue. I was actually suspicious of selecting the object to be the cause, but then i tried selecting the object > locking the details panel to that object > de-selecting the object > apply trans/additive material, and it crashed again. If Unlit mode helps than it’s good news but what happens when you play?

Update: It didn’t help me for some reason. It crashed once i switched back to Lit mode(while nothing was selected.) And it also crashed when i hit play while in Unlit mode.

We are experiencing a similar problem here as well. But it in our case the selection has no influence.
We are seeing a fatal error about a shader not being found.

Couldn’t find Shader TShadowDepthVSVertexShadowDepth_OutputDepthtrue for Material Resource Some_Translucent_Mat!
With VF=TGPUSkinVertexFactoryfalse, Platform=PCD3D_SM5
ShouldCache: Mat=1, VF=1, Shader=0
Material Usage = MLM_DefaultLit, BLEND_Translucent, TwoSided, TSNormal, bUsedWithSkeletalMesh, bUsedWithStaticLighting

This happens only for SkelMeshes with a translucent material assigned to an element that has shadow casting enabled. When we disable shadowcasting for the translucent material, all works fine again. The visited codepath has a ShadowDepthDrawingPolicy with bRenderingReflectiveShadowMaps=true.

Just to add to that, it also happens on static meshes as well. So the type of mesh doesnt matter, However the shadow casting option of the affected material ID indeed does. So turning that off helps, but its hard to maintain that with multiple assets added each day, so fixing the core of this issue would be a top priority.

Hello again Jacky. I am also having the same issue while using translucency. Another bump in the road.

I haven’t had any success with the workaround either.

Hey Stimpanzee!

Try to import the transparent parts of your mesh as separate objects if you can and put them together in the blueprint, or disable Cast Shadows for that material in the mesh properties as suggested by Daedalus51. If not, we’ll have to wait and see if it gets fixed with 4.2. LPV is high on the list in the roadmap so it is bound to get fixed sometime in the future. :slight_smile:

Hi Jacky/Stimpanzee/Bah,

We had a bug report submitted for this from one of our licensee’s a few days ago.

Please remember that LPV is still being developed and worked on. There will be bugs and workarounds that will happen while Epic is working on it. For any other information on LPVs check out the Wiki (Link Here).



Thanks Tim!

Yeah, i’ve accepted it with all it’s bugginess but still thought i should let you know. :slight_smile:

Just wanted to update this post. This issue seems to be fixed in 4.5 for me.

Thanks Epic!