Why is my level rendering with low detail and no shaders?

For some unknown reason my map isn’t loading itself correctly… It’s stuck in pre-rendered mode. You know, the one in which everything is super low detail and your terrain hasn’t generated shaders yet. I have no idea why this is happening, but I’d appreciate any help you can give me. Thanks!.

Hi TSpartanT,

Have you tried rebuilding your level and if so, are you are in Lit mode? Also, what happens when you Play the level, do you receive any errors?

I have tried rebuilding the level, I am in lit mode.

This is the Log:

I’ll include the log in an attachment. link text

Could we also see a copy of your dxdiag? And have you tried testing this in another level or a new project?

In the top left of your perspective viewport, click the Show button. There’s a lot of setting that you can toggle, including anti-aliasing.

Hope that helps. If it doesn’t, post back here and we can continue troubleshooting.

link text

It’s only this particular project that’s doing it… Could it be because I changed the display settings a long time ago? As in anti-aliasing, etc. If so, how exactly do I change that back? I haven’t been in the engine for 2 weeks or so, so I’ve lost my touch. Thanks!

Didn’t, I just set it all back to default and nothing…

Any other ideas?

Go to the Edit tab in the top-left and open up Project Settings. Go to the Rendering section. On the top right of the window click Reset to Defaults (this will only work for the section you are in).

If that doesn’t work, try doing the same to the Editor Preferences > Viewport, also located under Edit.

If you hit ‘Set as Default’ after changing them the first time, when it resets to default it will reset be your changed ‘defaults’ and not the factory settings. If you think this is the case I would suggest opening a new project and compare the two setting side by side.

That hasn’t worked either, I have no idea why… It just started happening one day.

Go to the Quick Settings tab on the Toolbar and look at the Engine Scalability Settings. Mine are set to default.

Also, could you post a screenshot of what you’re seeing. Even if this solves it, just incase anyone else has the same issue.

What I had wrong, just incase anyone else is as dumb as me and messes this up:

I had my Engine Scalability settings to Low, and Material Quality Level also low.

Material Quality was the reason all my stuff was messing up, it made terrain not compile shaders correctly, and wasn’t loading it fully.


No problem, I’m glad you got it sorted out.

Have a good day.