Why is my game failing to launch due to missing 'LeapMotionController'?

I am trying to launch my game on my desktop from the editor, but I get a pop up message saying this:


Why is my gaming failing to launch because of this? I have never used anything called Leap Motion. What is it and why is it the lack of having it causing a launch failure?

Hello ,

If you don’t need to use the LeapMotionController plugin and it is failing to build for you, you should be able to disable it under Edit > Plugins > Input Devices. This plugin is to allow for the use of LeapMotion controllers which are a type of motion controller. If you do want to get it working however, could you provide the logs from when you try to package? It could include some warning or error messages that could point to the problem. Also, are you using a Binary build downloaded from the Epic Games Launcher or a version that was compiled from Source from Github?

Exactly the same problem here so let me add some extra info.

We just upgraded to 4.11 by checking out the source.

The plugin is not activated and have never been touched!

The build-process works fine (except for the massive amount of warning that unreal always prints, but that’s nothing new…)

Here is our complete build log: https://gist.githubusercontent.com/PhroZenOne/8b7eac28176e7391633c15fdd3df827f/raw/2d0860eab73fa1a642815a71bd8c7afb3e5dc977/gistfile1.txt

Hey @PhroZenOne and @,

Could you open up the LeapMotionController.uplugin file in a text editor? Should be located at Engine/Plugins/Runtime/LeapMotionController/LeapMotionController.uplugin


"EnabledByDefault" : true,


"EnabledByDefault" : false,

Save and rebuild your project and let me know the results.

that must be a bug in 4.11, havent tried it yet, but the leap motion controller is a virtual reality hand tracker that allows you to track your hands in the game, and is used with oculus rift and other vr devices. its plugins for unreal werent the best (at least months ago they wer like that) but the unity ones are really awesome, and i highly recommend you check it out

I did have a LeapMotionController folder under Runtime but it did not contain anything. So in case of something went wrong when checking out 4.11 I removed it all and and cloned the complete repo again. Ran Setup.bat, fixed the Version.h file for compability and then build the client. This time there is no LeapMotionController folder at the position you said and it still responds with the same message.

Here you can se the result of git status and git diff:

And here is the full build log:

EDIT: I’ve just realized that you might have been talking about the LeapMotionController.uplugin in the finished client. It does exist and if I set endabled by default to false the error goes away. So I have just removed all files in the output folder (the folder pointed out by the -archivedirectory argument for RunUAT) and will try to build again.

EDIT 2: Cleaning the output dir fixed the problem! So, note to self. RunUAT Builds does not clean the output dir. :slight_smile:

Hello ,

I checked under Edit->Plugins->Input Devices and the Leap Motion Plugin is disabled. Since I am not compiling from a source on GitHub, I am building from my own project locally launched from the Epic Games Launcher.

Hey jengholm,

i opened the LeapMotion.uplugin but there is no field for “EnabledByDefault”

Seperate LeapMotionController from LeapMotion, it was the controller that was messing with me. But when you build your project, do you always point out the same directory? In that case it might be the same problem as I had. Point to a new directory (or remove content in the old one).

@ check LeapMotionController.uplugin, not LeapMotion.uplugin

Good to hear.

@PhroZenOne and @jengholm

I don’t see a LeapMotionConroller.folder under Engine/Plugins/Runtime

@ The file must exist - for windows you would find it somewhere similar to:
C:\Program Files\Unreal Engine\4.11\Engine\Plugins\Runtime\LeapMotionController

Nope not there =/

It seems like this could be a conversion issue related to the LeapMotionController Plugin being replaced with the LeapMotion Plugin, or at least renamed. Even in my own Binary installations, the LeapMotionController plugin is present in 4.10 but not in 4.11. It’s replaced with LeapMotion instead. If the project you’re having issues with is from a previous version, could you try using your 4.10 copy (or the version it was on prior) to Migrate the content to a new 4.11 project via the editor’s content migration tools?

Hey ,

thanks, that did it!

Hey ,

thanks, that did it!

I’m glad to hear that this fixed the issue. Although that fix does work, we would like to fix the problem at the root so that the conversion process works correctly. Would it be possible for you to privately share a copy of your project from 4.10.4 so that we could have a reproduction case for this issue? This would help with our effort to fix the problem. If you would like to do so, you could upload the project to a third party filehosting site and send a link to me via a private message on our [forums][1].


This fixed it for me: Remove the folders “LeapMotion” and “LeapMotionController” From: “\Program Files\Epic Games\4.11\Engine\Plugins\Runtime” Folder

Also have this problem. After packaging game its failed to start with error message about “LeapMotionController”.
I dont use anything related with it but also trying to enable\disable plugin in editor with no success. I also dont have “LeapMotionController” folder as suggested before, only “LeapMotion”.

I was upgrading my project from github 4.10.4 version directly to github 4.11.1 version of engine. There was some work already done in project so starting again from 4.10.4 version is not cool. Any help?

Hello , have you tried migrating the content/source as mentioned in my answer above? It worked for the original poster of this issue so it may work for you.