Why is my file size so large?

When I create the BluePrint first Person and Package the project for win then the project has over 500 mbs. Even I try the shipping option.

Seems there is no fast option.
Is it possible to reduce the file size ? Not just some few mb s?
Or this is it?

Is the engine so Hungry? Please I need serious Answers.


Make sure to not include to the starter content + delete the save folder (in this folder are just your log, autosave, backup files)

Thanks for reply.

if I delete the starter Content in the Browser and make a package, and start the exe, all removed objects in the browser and Materials are still there… also how to remove the starter content???

Going to the pakaged files (Engine/Content)and delete the files by hand int the content folder??? That cant be a serious workflow!

…and delete the saved folder in the published files, doesnt change anything because its only 500 kb that doesnt shrink down the project in any way…

Thanks for your help

You can disable the starter content when you create a project (a little box that you can check/uncheck) → but when you have already created your project, you can just delete it in your content folder :wink: → then the size will shrink e.g my first person shooter made with the fps template just has 60 mb

Thank you very much for your advice. I had never seen the little box. I was scared that the minimum for a game is 500 MBs.

Thanks a lot

Hello one more question.

I load the starter fps template, Include starter Content unchecked. Now I am on my fps template. I delete everything in the content browser and import my meshes for the game. Now with my new level created I package the game.

Now I m going to start the exe Butt ALL I SEE IS THE STARTER CONTENT and I dont see my meshes nor my level.

Why it does not export my own build level???

You say you get it all down to 60mb? is that including the engine and everything? I tried creating an empty blueprint with no starter content, just a cube in it, if i pack it with directx 11, the content folder is 30mb and the engine is 150mb… I’d really love the help.

Hello everybody.
I create my project with the blank projet with the starter content.
To reduce the size I migrate the persistant level into a nex blank projet (with starter content) : everything works fine.

If I try to migrate to a blank projet without the starter content, i see my imported folders in the content browser but the scene is the default scene. Nothing from my content is in the world Outliner…

Can you help me ?
Thanks a lot.

Can you see your level? Have you update Editor start up map after you migrate to the blank project?

Thank you for your reply.
No I don’t update the map…
It’s working now, I’ve changed the startup map in project settings with the good one.
Thank you VERY much CKong !