Why is my editor locked at 15fps?

Hey guys,

So I’m using an Alienware M17XR4:
Intel Core i7-3610QM 2.30GHz Quad Core
nVidia Geforce 660M 2GB GDDR5
12 GB Ram
128GB 840Pro Samsung SSD

And whether I use the engine in low quality, high quality, or even just a simple basic empty level with a single light. I seem to be locked at exactly 15 FPS. I’ve attempted to make sure all my settings in nVidia control panel are using my nVidia card. Now for some reason My processor is using no more than 50 Percent of it’s overall usage, and only 4 of my 12 GB ram is used.

Can anyone tell me why Unreal refuses to go higher than 15 fps?
Cheers guys,


I would guess the gpu is the issue. OSX users all seem to be having same issue.

You will suffer with mobile GPUs while working in the editor no matter what. I don’t know how that person is getting 45fps(probably an empty project) but it doesnt sound realistic to me after hearing so many people having frame drops with mobile gfx. :\

I’m averaging between 45 and 55 fps in the Reflections demo with a 7970m.

That’s new information then. All i’d heard until now were nvidia 600 and 700 series gpu’s.

I’m using Windows. :confused:

If your Graphic Card is already updated try to limit your fps.On the top right corner of the main Editor window in the console command type “t.MaxFPS 30” to lock the Editor FPS to 30.

But thats still a mobile gpu isnt it?

Yeah it’s still Mobile, but I’ve read on the answerhub someone with a 660M also running UE4 at 45FPS, so I’m skeptical, but technically my specs should be fine to at the vey least get 25-30 out of the engine.

Tried ‘t.MaxFPS 30’ still not having an effect.

Gave it a try, doesn’t seem to be having an effect.

Yep, I’ve read an answer here that someone had a 600M and was getting 45 fps from the reflections demo though.

Yeah it makes sense I guess, A friend of mine is using AMD 7970M in his Alienware, and is hitting 45FPS consistently. Then again it has a transfer rate of 130GB/s were my 660M has 64/s.

It appears so,