Download

Why is blueprint component shadowing still a problem??

Hi forum

So I want to use blueprints to build parts of the architecture of my level, much like the Bp_fence blueprint that you can find in the content examples.

What worries me about doing this is that I’m forced to use Ray Traced DistanceField Shadows to avoid getting shadowing errors as you can see here https://www.youtube.com/watch?v=kmnC6IUPGjI at second 11:10 . (The placed components of the blueprint don’t shadow correctly from a distance.)

Some time ago i was trying to overcome this problem by baking all the blueprints components procedurally in to StaticMesh Actors. here is my answerhub post

https://answers.unrealengine.com/questions/101918/permanently-spawn-a-staticmesh-in-to-the-level-edi.html

I tried getting this done in c++ but it went over my head and I finally drooped it coz the idea of this blueprint was to speed things up but the time required to get it working was kind of defeating the purpose.

So now, with the release of 4.7, for what i can figure with the new In-World Component Editing feature it’s actually encouraged to approach level creation by adding components (Blueprint or attaching to another staticmesh Actor)

But in my tests it seems that the shadowing issue still persists if ray traced distance field shadows is not enabled.

a868453465e023cc12523ac48e40329faee0e531.jpeg

(Shadows leak between walls made by component based StaticMeshes)

So my question is; am I doing something wrong and there is a way of using blueprint components and get proper shadowing without using Ray Traced DistanceField Shadows ??

And if the answer is no … is activating Ray Traced DistanceField Shadows like the official fix or is a another fix in the works for the default baked lighting system?

Sorry if this has been asked elsewhere i have searched and searched and not found an answer.
Thanks for your time guys.