Why is a spectator pawn spawning instead of my default pawn?

I have the correct gamemode selected, the spawn players as spectators checkbox is unchecked and the correct Player Controller HUD and GameState blueprints are being instatiated, yet the player character is spawned as a spectator pawn. What gives? Is this a bug, or am I doing it wrong? Images attached:

album: Imgur: The magic of the Internet

1 Like

Can you also post screenshot of your GameMode setting?

See the last image of the album.

See the last image of the album:

so i just went through this myself somehow it ended up getting set to simulate rather than play… under active play mode make sure its not set to simulate took me like an hr of angry button clicking to figure that out lol

1 Like

Same here… only 3 hours of frustration, including trying to figure out what was being called, rolling back sourcecode to see if I broke anything (didn’t work, meaning it had to be something “outside” the code/scripts/maps), trying to see if any project settings changed, and desperately uninstalled and reinstalled the engine in the hope that whatever was changed would revert to default (nope, it didn’t).

Found this post and yeah, this was it. Must have accidentally hit alt+s and switched to simulate at some point. Setting it back to ‘selected viewport’ and then clicking play did the trick… Normality has been restored, thank you!

Same here, after doing some major coding for my game system suddenly the pawn just stop showing up, and everything goes red. Just the simulate option is on !!! :tired_face: :tired_face: :tired_face: :tired_face:

Sorry to bump up this topic, but in case it helps everyone out there, be sure to check that you added your new game mode to both Project Settings and World Override.

image