Download

Why I cant change lightmap resolution from the static mesh editor?

I set the light map resolution on 512, but it is ignored. I tried reimporting the models and building the lighting but the lightmap resolution remains 64.
82561d0ea8d59228082b46e3d70e3e1a39398914.jpeg

Setting the lightmap override in level works though:

70a47184612e3563ce616833692c92e1726d8e48.jpeg

The override thing in the detail panel works as well as in the Static Mesh Settings properties. Perhaps don’t forget to ‘save all’ before rebuild your lighting :wink:

It would seem to be a bug then. Will post this on answerhub

What you are changing there is the MINIMUM lightmap resolution for when you are generating light map UVs, so the algorithm knows how much padding it needs to give your UV’s to avoid light bleed. You need to scroll down, and find the section for lightmap resolution, and change that instead. It’s under static mesh settings. It’s not a bug. :slight_smile:

You are absolutely right, thank you very much

If you are using large enough lightmaps you usually have spare for extra padding. You can add extra padding by using lower value for min lightmap resolution that you are actually using. This way you can usually get away bit smaller lightmaps or compression artefacts.