Why I cannot jump into the water?

I completed all the steps according to the tutorial of the “Swimmable Water volum”,the url:A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums.
But when I play,the charater cannot jump into the water like the tutorial.ae4fcf13df612a461cff8872d5386c21408e9bbc.jpeg,however,I can float on the surface of the water.
But the tutorial is


What should I do to fix out the problem,thanks!

Double click on your water plane in the content browser - collision - remove collision :slight_smile:

Thanks bro!But there is another problem:When I jump into the water,I can’t see the water material inside,then my character will be adrift,then I can see the surface again,but when my view looks under the water again,I cannot see the water material,neither the surface…d98e1e30463e38049193a71c7226150ba91e282c.jpeg0dd7fcf6c13bd07a7c6cc9f96bf2b4ae9a8242eb.jpegfb97c4e87783d87e642be05cc46e929f6360b0af.jpeg

Try ticking the material as two sided. In the material editor click on the main material node and under it’s ‘Material’ category in the Details panel the ‘Two Sided’ Checkbox is in there.
–To be honest i have no idea if this should be done with water materials, it may be inefficient, but this will allow it to be viewed from both directions.

I’d probably create a special water plane that has 2 material slots one for top and one for bottom since anyway the views will be different

thank u bro,never mind,I think is the problem of the plane,it’s just a flat,not a box room,but thank you

You’re also gonna need to make a post process material for faking underwater effects when the camera is in the water volume.

you mean to make a box material of the water?I did,but not work.

you mean to make a box material of the water?I did,but not work.

Enable two sided in the material + add a post process effect and play around with the settings (scene colour, blur,…) → Underwater technique - Rendering - Unreal Engine Forums :slight_smile: