Download

Why don't painted trees have LODs?

I’m working on a project with some samples from SpeedTree, and when I paint them on the terrain they only work with LOD 0, but if I place them manually all the LODs work.
Is this a bug, or is there something I’m missing?

Hi Luis,

This doesn’t appear to be a bug on my end. I’ve just tested this with the Broadleaf_Desktop sample form SpeedTree with no issue.

When I imported I left all default settings with exception that I imported Billboards with the other LODs.

There are four LODs total (Three LODs and Billboard).

Default settings were used for LOD as well with exception that I changed the density to 1.0 so that I could paint a few in an area instead of a lot.

Here is a wireframe of the foliage working with LODs:

Foliage_WireFrame_LOD.gif

**Here is a wireframe of the foliage working with LODs:
**
Foliage_Lit_LOD.gif

As far as I know the foliage tool is still not supporting LOD’s properly (probably it’s different with speedtrees + the latest version) :slight_smile: Which version do you use?

https://answers.unrealengine.com/questions/69461/static-mesh-lod-not-working-on-foliage-actors.html

Edit:

Ok, just tried it and it works :slight_smile: Could you probably share the uasset file so that we can try it out?

Maybe I was using an older version (even though the filename was the same) of speedtree samples. It’s now working properly! :slight_smile:
Thanks for the help guys!