Why don't I have a cube mesh

Why don’t I have a cube mesh and how do I fix this,when ever I try to drag the cube onto the scene nothing happens and in the BP editor when I add a cube component it just adds a static mesh instead of a cube, PLEASE HELP

hmmm you may have deleted it from the engine content haha. i would try closing the editor and going to the launcher and instead of clicking the launch button hit the arrow next to it and then click verify. that should verify the files and correct issues. it may or may not work though ive never had that issue that i can remember.

Hello,

We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

Did you ever get an answer for this? I’m running into the same issue for my final project - suddenly a bunch of my walls, floors, sidewalks (anything I used a Cube mesh to make) is gone. Additionally, it’s not appearing in any of my other projects/scenes either. It’s like the entire Cube mesh was deleted/lost from Unreal.

Any help would be much appreciated!

Was this created as a bug yet?

Is there an answer to the bug? If so please put the answer here because I cannot find the bug at all.

Finally if you are encountering this I highly suggest to stop working on your project right away to prevent everything from breaking apart, do not attempt to open another project as you will get the same result, every projects from unreal get the issue as they share the same basics for the cube mesh.

I will see if there is a way to repair unreal engine without uninstalling everything and ill come back, hopefully this works so we have a work around at least.

Thanks for ThompsonN13 that had the answer…

The easy but longer fix is has he mentioned to do a verify on the project. I was confused as I was using the unreal engine launcher but you need the epic games launcher to see this option.

Here is what you need to do for those like me that like a good picture. (in EPIC GAMES launcher)

The second fix option is to paste the file manually to save time.
In [attachment here][2] you can find the cube from unreal that needs to be in this folder:
\Epic Games\UE_4.21\Engine\Content\BasicShapes