Why doesnt this simple thing work?

When I press z, the cube doesn’t relatively rotate. But when I plug event begin instead of z to the rotate node , it works.


Have you checked whether the ‘Z’ event fires? put a print string between and see. It might be that the blueprint you did this in does not catch input. By default only PlayerController and Character (not sure on that one though) capture input.

Case 1: Your BP does not catch it - open it in Blueprint Editor and find in class defaults, under Input section ‘Auto Receive Input’

Case 2: It does but still doesn’t work - it means that either something blocks the input - there is a flag in the same place as before, or that there already is ‘Z’ event somewhere, that has the ‘Consume Input’ flag set to true.

Thanks for you reply! The scene is a basic empty scene with one character (player controller 0) and a cube. Thats it.

I tried everything you said. ‘z’ does accept input in level BP as I printed stuff in between and after the rotation node. Enabled auto receive input as well but still didnt work.

Its so weird that it even DOESNT work with event tick instead of ‘z’. But DOES works with event begin play.

I mean if you want to have a slow relative rotation with event tick it doest even work. Is it a bug?

Alright guys, apparently I did not set the mobility to dynamic. Now it works!

I am also now trying to get player controlled character to rotate. But the character itself isnt rotating. I will post here once I get the answer.

Set the mobility in the setting to Dynamic/Movable!

For Character, use set control rotation node instead of relative rotation node and connect that to player controller.