Why does UE 5.2 keep freezing when I try to import a skeletal mesh?

Hello.
Lately I’ve been working on one of my projects and found that when I try to import a skeletal mesh, the editor just freezes; no crash report or anything. Static meshes seem to import with no issues, and there is no trouble if I import a mesh with an already existing skeleton in the project. I’ve tried switching over to version 4.27, which works seamlessly with no crashes whatsoever. I have to go to my task manager to close down the software, since nothing else in the editor is enabled.
A few notes:

  • I use blender to import meshes with
  • I have installed the latest nvidia driver
  • I have the newest engine version
  • and my crash report client doesn’t show up.
    Has anyone got a clue to this issue?

Hi! Have you solved that? I’ve got the same issue: when I import an object with a skeleton, UE 5.2 freezes.

1 Like

Someone on reddit solved it (Their name is CodeVisionary). When importing form the file explorer you will see a window in the bottom right where you should be able to select “SkeletalMesh.fbx”, which works for me. It is set to “All Files” by default which freezes the engine.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.