Download

Why does the light not bake smoothly onto my modular meshes?

Every modular piece of the scene renders in a different shade, rather than a gradation as expected. Any idea?

Thanks!

This tends to happen when you have static/stationary lightmaps and modular meshes that have a seam on a flat surface. The way I usually mitigate this, and it works about 98% of the time, is with these lightmass settings:

Static Lighting Level Scale: 0.1
Indirect Lighting Quality: 10
Indirect Lighting Smoothness: 0.6
Environment Color: Change black value to a very very slight shade of grey (Usually about 0.05 in the Value slider)

Bake times will go up, but I’ve managed to eliminate most of these occurrences in my projects with these settings

The only other alternatives I believe are dynamic lighting (doesn’t look as nice or perform as well), and making your meshes only end on corners, and upping their lightmap resolutions to account for the increase in surface area that now needs to be covered by a single lightmap.