Why does the Editor stutter/hang after light baking with 4.4?

Since updating to 4.4 we encounter a strange bug on all of our machines.
After succesfully baking the lighting in our levels, the editor starts getting laggy/begins to stutter for a while.
When we move inside the viewport, it hangs for a while until we are able to move again. It feels like the right mouse button doesn’t get recognized properly as well, because it starts to open the right-click-menu when moving around as well…
It get’s better after moving around inside the level for a few seconds/a minute, but it isn’t really great to work this way…especially when working on initial light setups and stuff like that.

The problem did not exist in previous versions (even the 4.4 Preview didn’t show it)…so we are not really sure, where it came from. We already tried deleting the “intermediate” and “saved” folders inside the project to see, if some caches are faulty, but this didn’t help either.

Are we facing a bug here? Anyone else having the same problems?


Is this only happening in your project or are you able to reproduce this in a new project?

Are you able to compare this with a build of your project on 4.3.1 as well?

Thank you!



Since I’ve not heard back from you in a few days I’m going to mark this as resolved for our tracking purposes. If you’re still having the issues can you please post the requested information above along with any relevant information.

Thank you!


Thanks for your feedback. Sorry for the lack of reply so far. We couldn’t find any time to try it in other versions or projects so far. Our workload here got a bit crazy. We will be starting of a new project in a week. I can check how things go then and let you know, ok?

Thanks so far

That sounds great! Let me know how it goes and when you can, if it’s still giving you issues I’ll definitely get this looked into.

Thanks for getting back to me! :slight_smile:


Ok…we had some time to set up some new tests. The error still persists on several machines here in the company…also with the newest 4.4.3 release.
The engine runs smooth otherwise, but after light baking (and after storing all the lightmaps and all this) the engine becomes laggy/stuttering for a few seconds while you move through the scene (untill it catches up again and starts to react as usual)
It seems the editor has some problems with processing all the new lightmaps/lightmap-LoDs, because it always stutters when you move to and away from objects, that got new baked lighting…

All we need to do to replicate that problem is create a fresh scene, add some lights to it, some objects and then fire away the light baking. After the baking it stutters for a while. Doesn’t matter if you leave the editor idle for like an hour after baking. The error “waits” for you until you move through the scene, thus my suspicion about problems with the storing/retrieval of Lightmaps/Lightmap-MipMaps…

It would be great, if you could have someone looking into all this. If we can do anything to help the process, let us know

I’m afraid I’ve not been able to reproduce this on my end. I am running a fairly high-end machine though.

Can you attach your DxDiag (Start Menu > Run > DxDiag > Save all information and attach that here)?

Would you also be willing to do a video of the stutter that’s happening? I know you gave the scene repro but did you change any of the LM resolutions or are these all the default settings?

Thank you!


Hi Tim,

thanks for getting back at my issue.
Too bad, that you can’t reproduce our problem on your end straight away. We are not sitting on the lowest tier of computers here either (3D-VFX-Studio ;)) but i understand the point of yours.
I attached the DXDiag-File for you. I am sitting on the oldest pc here at the moment. The others have more recent XEON CPUs or Core i7s (Devils Canyon) and GPUs that range from GTX 460 to GTX 780ti…

I would be absolutely willing to record a video of the issue we are facing…unfortunately i am not sure, how soon i will be able to do so. I’ll try my best to make this happen tomorrow. Our schedule here is pretty packed atm and as the issue isn’t exactly a show stopper right now, we have to see, where i can put the priorities. We are very much able to produce great things with your engine anyways, just so i left some nice words here as well :wink:

I’ll see what i can do about the video, as the issue is really a little annoyance here that i would be happy to have it fixed.

By the way…the issue is more prominent with larger scenes (so with many more lightmaps to store)…
We are creating ArchViz-VR-Environments of office buildings here at the moment…so the scene size and object count isn’t that small…maybe this adds to the problem.
I’ll have a closer look into it as soon as i can. Thanks for your attention so far.

A couple of other questions since you’re using larger scenes.

Are you using any Landscapes? if so, size and LM resolution?
For your larger buildings what is the LM resolution you’re using with this?

We do have a feature in the engine to record the last 20 and save this file. This may be enough for you to show the issue.

To use this you will need to create a shortcut of your editor.exe from the Unreal Engine folder. Open the properties and add the following to the end after the quotes:


When you start the project/editor back up you’ll see a little record button in the top right next to the source control icon.

When you get the issue to reproduce and you hit the record it will not record anything new. It will take the last 20 seconds of actions and save this to a folder.

Looking at the DxDiag everything looks good. Whenever you get the opportunity I’ll take a look at the video and see if I can keep trying to reproduce on my end.

Thanks for the help in trying to diagnose this!



no Landscapes were harmed during the production of this…sorry…
No, we are not using any landscapes here. It’s strictly interior viz atm. Lightmap-resoultions range from everything between 64 and 1024 (only rarely used on large objects like floors). Packaged Lightmap-size has been increased to 2048…we turned of Lightmap-compression lately (hasn’t changed anything about the problems…they were there before and are there still)

Thanks for the hint about the recording-function. I’ll look into that as soon as i can.

Thanks for all your effort in general


Are you still noticing the lag with higher lightmaps? I’ve not been able to reproduce this on my end or noticed any other members of the community mentioning this type of issue.

Since we last spoke I’ve worked on a couple of side projects that have a heavy use with lightmaps but no lag that you speak of. We also used 64-1024 for our LMs as well.