why does my UE5 lag when pressing the ui?

What I mean is that whenever I press file, edit, window, camera speed button, etc. my UE5 lags, my mouse moves like 2fps. However when I make the UE5 smaller, this doesnt happen. Any solutions? Note my pc specs are pretty high end so I dont think that is the problem.

Greetings Online_Learner_gwm7o, thank you for posting your question and welcome to the Unreal community.

Your concern is a bit interesting and since I do not know the specs of your PC, I can only ‘speculate’ the cause. User watcheroftimes had a similar concern and their solution resulted in them altering a setting in their GPU.

The other solution posted by Mrclone2 involves you going to your tool bar and unchecking ‘Realtime’ in your viewport options. You can also do this by pressing CTRL+R on a Windows PC.

Here is the relevant thread.

I hope this helps.