Why does my terrain have collision issues?


I’m facing issues when I have meshes colliding with the terrain. The object apparently ignores the terrain and just goes through it. I’ve tried with many different mesh settings (both in the mesh editor and the physics/collision section of the actor) and it doesn’t change anything. I’m not sure if I should file this under “bug reports” or in “using UE4” since I’m probably messing up the settings somewhere. Just in case, I would appreciate it if you would tell me what settings would need to be applied to the terrain / mesh in order to make the mesh bounce off the object.

Thanks in advance.

What collision settings do you have applied to the cube?

And is your Landscape’s collision set to BlockAll?

Yes, it is

It’s a raised part of the landscape that I am walking on.
And sorry about that, I was in a bit of a hurry when I recorded it :stuck_out_tongue:

It’s hard to tell in your gif because its a bit dark. The wall that the cube goes through, that is just a raised part of the landscape you are walking on correct? Or is it a separate mesh or another landscape intersecting?

Its no problem. I set everything to your settings but still haven’t been able to reproduce it. I do remember seeing something a while back about collision sometimes acting weird on steep landscape inclines. I’ll keep looking into it. In the meantime could you try reproducing it in a new level and a new project? Just to see if it is confined to that single level.

Its not a problem at all. I’m glad you found a work around. If it happens again please post back here and we will dig into it further.

Have a good day, TJ

Eh… This is a bit embarrassing, but it works when I create a new level. It still does not work on the previous one though. I can’t seem to figure out why :S

I created a new terrain on that same map and it works now for some reason. I’ll just recreate that terrain. Thank you, and sorry about wasting your time XD

paragonx9 - this is most definitely not your fault - remaking the map is actualyl the only fix that I know of so far. I am having the same problem as well… Using version 4.4 and it clearly isn’t fixed - I read about this issue in many places and it seems like a serious problem in UE4. Surely there has to be some official fix coming this way for it. I really don’t want to remake my landscape, please… I have applied a lot of props, vegetation and tons of manual vertex paint :frowning: please help!! CCD doesn’t help at all with this situation. Only pawn collision works which is rather rarely used.

EDIT: I meant to say version 4.4.2, sorry, it was late >.<

I had that issue quite a lot when using terrain. Suddelny collision is gone. And the only way to have terrain collision again is to create a new terrain. I have seen quite a lot posts about this issue.

I also had that problem again with 4.3 after the fix, that might have fixed something, but not this problem.

Just search for “landscape collision” here and you will find people still having problem.

I have just opened a new ticket for this problem. It needs a lot more attention that it has been given so far, apparently. The problem floats around for a long time now and I’m sure it happens to many, even though only a few actually report it here.

I have the problem too. Ill try creating a new project . Atm, I exported a terrain from unity via 16bit raw format windows, and imported into ue4. I never used to have this problem, so I was indeed wondering what the deal was. I made a new project and it doesn’t do this . Sigh , I must be able to import that terrain as it would take far too much work to recreate it in UE4. I guess I could try importing raw into PS and exporting a PNG.

Hope this gets resolved as im stuck at this point.

cheers nl

Hi neighborlee,

Which version of the editor are you currently using?

Figured out on forums…I had to go into quicksettings and set ,quickserttings > engine scalability > EPIC,and voila…instant fix.

Ty anyway tj :wink:

Another report from me: I created a terrain in 4.4. Then converted it to 4.5 preview. Now I opened it with 4.5 and added a pawn for the first time. It successfully stands on the terrain, but when I drive over a particular flat area (that I did not elevate), the buggy drops in the space below. I decided to raise the terrain in that area to see what happens. Now there is a new problem - the buggy collides in invisible objects and cannot even go over that area any more. I have no problems with other areas of the terrain, not even with other flat areas. I tried building the project. I also tried to find a way to visualize the collision shape of the terrain, but there doesn’t seem to be a way to do it. The things that the buggy collides into don’t feel like simply invisible objects - the way it reacts is really strange.

I found the best solution for me yet - Delete certain components from the landscape and Add new components in their place. (The engine tries to construct the new components so that they fit nicely in the terrain.)

I am not sure what the exact behavior is, but I have a feeling that when I did this, some other components that were not working before, got fixed as well (without deleting and adding them).

I tried this approach because in my case the problem was only in a small part of my terrain - the pawn was dropping into the void below, as if there was no collider. The rest of the terrain worked fine.

And of course, I think that this needs a proper fix…

Oh! This one works for me! But now I’m worried about the framerate…