Why does my Geometry brush reset when scaling with the details panel?

Whenever I try to edit a brush in my level it seems to revert to some kind of default position. For example, I position a brush precicely and rotate it into place, but then try to edit the scale- as soon as i click on the tool/widget, the brush snaps its rotation back how it was before. Same happens if I try to change the x y or z data. I guess the solution is to scale it first and then position it but I feel like I’m missing something fundamental here.?

Hi integration,

Try building the geometry after you move or rotate your object. Also, have you tried testing this in another level or a new project?

Hi Integration,

This is actually a known issue. There has been a bug report submitted for it, but unfortunately it’s not known when it will be addressed.

The problem as you’re seeing it and I’m going to repeat it here step for step so that anyone else who has the issue is aware of it.

When you create any BSP/Geometry brush in the editor window.

If you scale or rotate within the editor window to adjust the BSP/Geometry brush and then use the details panel to change the settings it will revert back to the scaling there.

The reason for this is that the the BSP/Geometry brush is not updating the information in the details panel.

I know this doesn’t help your situation, but I hope it explains what’s going on for you and that we’re aware of the issue.

Thank you!


Thanks Tim. I’ll stick to using the tool then, rather than the details panel. Is there a way to rotate the transformation tool? Because it sometimes sits at a 45 degree angle to the brush I am trying to scale- which is why I was using the scale properties in the details panel instead.

Hi Integration,

From what I can see there is no way to adjust this. With BSP Brushes the transform tool will always stay the same for rot, scale, and movement. However, if you were to convert it to a brush the same again is true for rot and movement. BUT the scaling will stay relative to the way the pivot was set up. X, Y, and Z scaling will stay the same no matter how it’s rotated.

Thank you!


Still no solution to this problem?
(I didn’t check last versions in detail so I’m not sure)
Can I hope to see it fixed in 4.17?