Why does my editor go black when I move with RMB and WASD?

Essentially title. Here are photos of the before and after in my editor. I hold the Right Mouse Button and attempt to move with WASD and my editor turns black. I am able to move with just the mouse with no issue. I saw a reddit thread (https://www.reddit.com/r/unrealengine/comments/u4eoim/menu_shows_new_window_of_unreal_engine_screen/)
where they said go into the Nvidia control panel and turn off your MFAA. I tried that and it did not work.

Working:

Black:

Any and help would be greatly appreciated!

Happened to me also.In my case the directional light actor colour was set to blue. Setting it to white instantly fixed it.

Hey @joeythefake! This is definitely an odd issue. Any way we could test this on the other maps? It is sounding like a graphical rendering issue off the bat, but we should cover our bases. I’m sure you already did this but I have to go by the book and mention it, have you updated your Nvidia drivers? We’ve had issues with a couple of the recent in between stable Nvidia driver builds causing something like this.

2 Likes

I tested on 3 other maps and it worked swimmingly. My Nvidia drivers are up to date, it looks like they released a driver update yesterday (08-08-22). I updated and still no luck. @SupportiveEntity

there is an Output Log at the bottom of the editor, click on it, see if there are any messages. the editor is writing there all the time, maybe there is a clue of what is going on

Ahhhh that’s odd, if it’s only that map try and get it to black out and check the output log like Doru had recommended and see if there’s any errors or warnings. If not, we may have to try a workaround to retain your level. If you can’t see anything in the output log, see if you can duplicate the level and see if it does it on the duplicate. Do you have any wild shaders on that level specifically? Lastly, might have to comb through and see what objects could be creating it, which can be significantly more tedious. Let me know it goes as this might require a bug report.

** I do still believe it’s a graphical issue but being confined to one level is odd.

This was my output log before moving.

This was my output log after moving.

There are no wild shaders that I am aware of. Everything in this file is dang near basic to the bones.

Also it is a GitHub level that I am sharing with two other individuals, whom do not have the same issue. They are are able to move freely using RMC and WASD. Fortunately I am able to move around and place items using just the mouse.

@dorusoftware @SupportiveEntity

Well it’s confined to one file, every level has the same issue, but other files do not have this issue. Coincidentally all my other files are not shared via GitHub. @SupportiveEntity

How very odd, if it’s related to source control it’d definitely be surprising. Are you guys working with a .gitignore and does it have any key filetypes in it?

It does not look like we are working with a .gitignore, but we are working with a .gitattributes. @SupportiveEntity

Gitattributes shouldn’t cause problem like this one way, it would destroy it for everyone besides whoever pushed it if that was the case. Attribute rules are only destructive if you make special rules, standard ones shouldn’t cause anything.

Honestly I’m kind of stumped unless it has to do with the way your GPU is handling it, DX12 or the VSMs, but all levels would have this issue as well.

@SupportiveEntity @dorusoftware It was my speed multiplier for my camera lol it was maxed out to 2 billion

Wow thanks for letting us know, I’m surprised there’s no hard cap on it.

Every time I go into the file though or switch maps I usually have to reset it. @SupportiveEntity

I wonder if there’s an entry in the configs/ini files that dictates that. That’d be the easiest fix if so. Still odd your defaults are set so high naturally.