Why does my actor fall through the floor on Play?

so I just worked my butt off for the first time ever using UE4, and for the life of me can’t figure out how to stop my actor from falling through the floor when I hit the play button to test the level… can someone help me with this problem please.

Hi AdamStar,

Have you checked to see that the collision is properly set up on your floor mesh? if not that could be causing the issue. Further, check to make sure the player capsule is sitting above the floor and that it isn’t too low as that could cause problems. Finally, in the dropdown menu next to the “Play” button. Please make sure that the game is directing the game to start at player start, not at camera location. If none of these work please let us know so we can assist you further.

Thank you!

Adam

If you followed a tutorial and are falling through the floor and/or get stuck and can’t move after clicking Play button and you didn’t have a Player Start added, press Shift + 1 to change to Place Mode, then click Basic and drag and drop a Player Start onto the level’s floor.

When you click Play after that it should work.

Attachment List: First Picture shows falling through demo level floor before adding Play Start, second picture shows Player Start.

Hi AdamStar,

We haven’t heard from you in quite some time. I am going to mark this as answered for tracking purposes. If you are still experiencing this problem please let us know so we can further assist you. Thank you!

I suspect your actor doesnt have a collider. Double click on it in the content browser and add one under the collider drop down menu. Should work then!

Thank you!

If you have proper collision set up, I would suggest ripping out your floor, and replacing it. Or I would add in blocking collision manually if worst came to worst.

Make sure your actor spawn is above the floor.

did you add a volume to set as you actor’s collision??plz check collision volume of your actor.i think there’s something wrong with your collision setting.

In the details section for your player character mesh, see if you have the box “Simulate Physics” checked or not. While I cannot explain to you why exactly, I do know that when fiddling around with physics stuff in the templates, I would be able to play a level fine, and then upon changing the value of that checkbox for either the floor or character mesh, I was falling through the floor.

Go on ‘‘blueprints’’, select Open class blueprints, type ‘‘My character’’ and go in the defaults (nest to components and graph), scroll down Physics and mesh, uncheck simulate physics. You sould be fine :slight_smile:

Hello, sorry but the same stuff is happening to me. I already tried the solutions on this page but it still doesnt work

What collision settings are you using? Does this only occur with one mesh or is it occurring with multiple meshes? What steps are you taking to reproduce this error on your end?

By mistake,I moved the floor way down when scaling and that messed everything up when I hit “Play”-the character was falling through the floor.I went to my left orthographic view and moved the floor just above the Y axis and it worked.

it’s only occurring with 1 stage of mine. 2 others are fine. but it hovers above ground on one of those others. maybe because there is a dip in the level?