Why does lighting build fail on linux?

When building light, I get the error “Lighting build failed”. I experience this problem in both existing levels and new levels (in new projects). I don’t experience these problems under Windows 10, with the engine downloaded via the launcher.

Some details:
I get the error message immediately after the “building lighting: 0%” pop up shows, the moment where in Windows 10, Swarm kicks in.

Hey bitwiseben-

I created a new project in 4.12.4 and was able to build lighting in a empty First person Blueprint project. Can you provide any other details about the project or setting you’re using? Is your project C++ or blueprints? What template did you attempt to build lighting for? Was your machine connected to the internet when building lighting?

Hi Doug,

I created a new project in 4.12.3 on Linux (Ubuntu 14.04): blank blueprint template, scalable 3d or 2d, no starter content. I did not change any engine / project setting, and my machine was connected to the internet.

Please let me know if you need to know anything else.

I have not seen a crash when building with 4.12.3 either. Can you make sure that ShaderCompileWorker and UnrealLightmass were built with the engine? You can do this manually by running $ make ShaderCompileWorker UnrealLightmass in the same folder location where you ran ./Setup.sh and ./GenerateProjectFiles.sh

I think they were. When I run suggested command I get the following (snippet with respect to UnrealLightmass; same with ShaderCompileWorker):

Building UnrealLightmass…
Using clang version ‘3.5.0’ (string), 3 (major), 5 (minor), 0 (patch)
Creating makefile for UnrealLightmass (UnrealBuildTool.exe is newer)
Target is up to date

Hey bitwiseben-

I came across another post where an anti-virus program was blocking lighting from building: Unable to build lighting - Rendering - Epic Developer Community Forums - Can you ensure that you don’t have any anti-virus program blocking Unreal or Unreal processes? Do you get the same lighting build failure in a new project? Can you post a screenshot of the full error message you’re getting?

Hey bitwiseben,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Doug Wilson

Hi Doug Wilson,

I’ve updated and rebuild the editor to version 4.12.5-0+UE4, and still have the problem. I’ve not installed any anti-virus program, and am not aware of any default anti-virus solution under Ubuntu.

I’ve added a screenshot of a brand new Blueprint First Person Template project, where I’ve done nothing but build lighting (only). I’ve also added a text file containing the output I see on the terminal (from which I start the editor).


Can you try building lighting in a New Level and if that fails, try in a New Project to see if lighting builds?

If it’s project specific or level specific you need to go through your world outliner and check that you don’t have any NULL static meshes in there. This has caused light builds to fail before. Beyond that, I’m not entirely sure with Linux since it’s not a platform I use.

Hi Tim,

I keep having this problem with new projects, and new levels (within new projects). I’ve carefully checked that there are no NULL static meshes.

Hey bitwiseben-

Just to confirm, you are using the Build drop down in the editor to choose the “Build Lighting Only” option, correct? Can you provide the full log from the Output Log immediately after the building fails? Additionally if it’s possible, let me know if you’re able to update to Ubuntu 15.10 or 16.04 and try building lighting again.

Hi Doug,

Yes, I’m choosing “Build Lighting Only” from Build drop down in the editor. You can see the full output log from immediately after building fails in the screenshot I provided earlier. In the same reply, I’ve also provided the output from the terminal, from which I run the editor.

I can’t update to Ubuntu 15.10 or 16.04 in the next couple of weeks, but will try to update thereafter.

Is the Linux machine connected to the internet when attempting to build lighting? If not, please try adding an internet connection. If lighting still fails to build with an internet connection, please provide any information about your machine that you can (CPU, video card, etc).

My machine is connected to the internet. Some additional information: it is running Ubuntu 14.04 LTS, has 16 GB memory, an Intel Core i5-6600 CPU @ 3.3 GHz x 4, a GeForce GTX 960 graphics card.

Hi Bitwiseben,

the problem is that there’s a leftover library, probably from some older build of UnrealLightmass:

/mnt/data/Source/UnrealEngine/Engine/Binaries/Linux/UnrealLightmass: relocation error: /mnt/data/Source/UnrealEngine/Engine/Binaries/Linux/libUnrealLightmass-Settings.so: symbol _ZN5FNameC1EPKc9EFindNameb, version UE4 not defined in file libUnrealLightmass-Core.so with link time reference
[2016.07.30-10.09.19:002][993]LogHAL: Child 24175 is no longer running (zombie), Wait()ing immediately.

This libUnrealLightmass-Settings.so needs to be deleted manually. Unfortunately, even cleaning and rebuilding UnrealLightmass may not fix that, since if module was moved or deleted, UnrealBuildTool will not know that there was a shared library like that and will not remove it, whereas during run time, the engine will try to open every shared library, not taking into account if it comes from a non-existent (anymore) module. Normally situations like that are resolved by putting the file names/masks into Engine/Build/JunkManifest.txt, but apparently this file was missed.

Yes!! Thank you, you’ve brightened my day :slight_smile:

In Unreal 4.17.2 libUnrealLightmass-Settings.so is not there still the same error. so which lib i have to delete ?