Why does it crash?

So I have a mac, and Im hoping to make a game as my exam for school, so my issue is that Unreal Engine 4 crashes right after 96% of loading in a project, and I dont know why, Can it be that OPENGL is outdated or is it just a bug? But Epic Games Launcher works fine.

Here is a crash log -

If that cant be opened -


 SEGV_MAPERR at 0x10

GetPrecomputedLightingParameters(ERHIFeatureLevel::Type, FPrecomputedLightingParameters&, FIndirectLightingCache const*, FIndirectLightingCacheAllocation const*, FLightCacheInterface const*) Address = 0x11848e6fa [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/LightMapRendering.cpp, line 151] [in UE4Editor-Renderer.dylib]
CreatePrecomputedLightingUniformBuffer(EUniformBufferUsage, ERHIFeatureLevel::Type, FIndirectLightingCache const*, FIndirectLightingCacheAllocation const*, FLightCacheInterface const*) Address = 0x11848fb7b [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/LightMapRendering.cpp, line 269] [in UE4Editor-Renderer.dylib]
FPrimitiveSceneInfo::UpdatePrecomputedLightingBuffer() Address = 0x11882759b [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/PrimitiveSceneInfo.cpp, line 612] [in UE4Editor-Renderer.dylib]
FSceneRenderer::UpdatePrimitivePrecomputedLightingBuffers() Address = 0x118944bc5 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/SceneRendering.cpp, line 1549] [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::InitViewsPossiblyAfterPrepass(FRHICommandListImmediate&, FILCUpdatePrimTaskData&, TArray, TInlineAllocator<4u, FDefaultAllocator> >&) Address = 0x11896287a [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Public/Stats/.h, line 1537] [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::InitViews(FRHICommandListImmediate&, FILCUpdatePrimTaskData&, TArray, TInlineAllocator<4u, FDefaultAllocator> >&) Address = 0x11896174d [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/SceneVisibility.cpp, line 2894] [in UE4Editor-Renderer.dylib]
FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x1182e8683 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.cpp, line 571] [in UE4Editor-Renderer.dylib]
FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::EURCMacro_FDrawSceneCommand::DoTask(ENamedThreads::Type, TRefCountPtr const&) Address = 0x118949040 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Renderer/Private/SceneRendering.cpp, line 1645] [in UE4Editor-Renderer.dylib]
TGraphTask::ExecuteTask(TArray&, ENamedThreads::Type) Address = 0x1189ef87b [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Public/Stats/.h, line 1537] [in UE4Editor-Renderer.dylib]
FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x1084077d1 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp, line 259] [in UE4Editor-Core.dylib]
FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x108403275 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformProcess.cpp, line 504] [in UE4Editor-Core.dylib]
FTaskGraphImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type) Address = 0x1083ffaf1 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp, line 1725] [in UE4Editor-Core.dylib]
RenderingThreadMain(FEvent*) Address = 0x10e548964 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp, line 320] [in UE4Editor-RenderCore.dylib]
FRenderingThread::Run() Address = 0x10e55c107 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp, line 473] [in UE4Editor-RenderCore.dylib]
FRunnableThreadPThread::Run() Address = 0x1084588a3 [/Users/build/Build/++UE4+Release-4.14+Compile/Sync/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.cpp, line 25] [in UE4Editor-Core.dylib]
FRunnableThreadPThread::_ThreadProc(void*) Address = 0x10841d2f1 [Runtime/Core/Private/GenericPlatform/../HAL/PThreadRunnableThread.h, line 166] [in UE4Editor-Core.dylib]
_pthread_body Address = 0x7fff9640799d (filename not found) [in libsystem_pthread.dylib]
_pthread_body Address = 0x7fff9640791a (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff96405351 (filename not found) [in libsystem_pthread.dylib]


I removed your email, because bots might sniff it and you can get nasty spam, Epic staff and other people will use this page to communicate with you about issue, point of anwserhub is to discuss issues publicly or else private data is involved

From stack it seem it is something related with memory allocation in lightning rendering, it might be not enouth GPU memory?. Even if it’s some incompatibility issues i don’t think crashes are desirable, so i will move this to Bug Raports. In mean time please give some more information, what Mac you using which version of OS X, also is it happening on empty or existing project? empty or template new project? if template which one? stuff liek that.

Can you give us an idea of what was last changed before this started crashing? Is this the first compile, or have you had it working before?

On first glance, I’m going with the theory it’s due to case sensitivity (from what I just Google’d, my theory appears to be correct), which appears to be a non-default setting on Mac.

Supposedly this bug was fixed last year, but I see you’re using 4.14 anyway. I know some of these questions didn’t get answered, but hopefully they can help give some insight.

Let me know if this has helped.

I tried a empty one, still crashed and I tried loading in my other template which still crashed. Right now I cannot get the mac specs because its with one of my friends, but Im pretty sure the mac is on its latest version

Hi ArthurEngineer,

I am unable to find your crash in our Crash Reporter data. Have you been hitting the “submit” button when the Crash Reporter pop up window appears? If not, please try to reproduce the crash, then select the “submit” button. We use this data to match similar crashes that may already be fixed.



Hi ArthurEngineer,

Thanks for submitting the Crash Reporter data to our Crash Reporter site. I was able to look up this crash along with it’s corresponding crash report: UE-29001. It was ultimately determined that “[this crash] is always from a machine running an old GPU that we don’t support.”

If you feel that this is not the case with your machine, please post your Mac’s specs and we will continue to investigate the issue with the updated data.