Why does input touch does not work while event begin inputtouch does?


I don’t know if it’s a bug I’m unaware of, but the input touch node isn’t working at all when I’m using it in a blueprint other than the level blueprint. I allowed touch and click events in the player controller, and enabled use mouse for touch in project settings. Event begin inputtouch works fine, it’s really just the input touch node that does nothing.

Any suggestions ?

Thank you.

Have you either enabled auto recieve input to player 0 on your object, or set your default player controller in the world settings? Also you might want to assign input actions in the project settings.

I had already tried to to enabled auto receive input, but just tried it again to be sure and it does not work. My player controller was already set in world settings. As for assigning input actions, I do not see any simple touch there, steam touch related or pinch and flick.

Those are not “Gestures” that are supported by Vanilla UE4. (Vanilla meaning unextended bare version of the engine). I might be wrong on this though.

Sorry, that sentence is missing a “only”. There is only steam touch, pinch and flick, which I do not need.

I only need to trigger something when I touch an object then trigger again when touch end, whether on or not on the said object.

Anymore suggestions ?

Mikhael you are right, they are actions supported by UE4, I’m sorry for my mistake. I reproduced your setup and I got it to work, although without a player controller. I put the nodes in the pawn blueprint…


1 Like

Just tried in the player pawn and it does work, not quite what I was aiming for, but I think I know how I will handle what I want to do. Thank you.

very welcome.

May be this link can help.

Tnx! ,Auto Possess Player set to player 0’’ helped me! :slight_smile: