Why does importing 3d assets takes so long?

Hi there!

I was wondering if it is normal that importing 3d assets from Quixel Bridge to Unreal Engine takes so long?
Importing a Sandstone asset (ca. 300mb of size) takes me round about 4-6 minutes to import. My pc isn’t bad at all actually…

Windows 10 Home
Ryzen 7 3800X
32GB 3200MHz ram
RTX 2080ti Gaming X Trio

Unreal and Bridge are both installed on the ssd.

Hope you can help me!

Update: now it took a 3d asset 9 minutes and 19 seconds…

If you’re sure that your computer has turn off other process check the import settings before import, something may be turn on that slow down your unreal engine.

There’s a number of operations it can perform on a new asset that can be very slow, especially if your file size is 300MB which is pretty big. If you don’t need them, turn off auto generate lightmap UV’s and auto generate collision. Especially if your mesh is complex and high poly those operations will be very slow and they’re on by default when you import. If you have your own lightmap UV’s set up for your mesh then you don’t need the auto option there, and if you don’t need collisions on the mesh or you have your own collision mesh then you don’t need that option either.