Why does foliage become a pale uniform color off in the distance?

I’ve included 2 images, the first shows the scene zoomed out and the second shows an up-close view of some of the trees.
When zoomed-out, the trees all take on a pale uniform color and when I zoom-in close, the trees become green like they are supposed to be.
For some reason the tree color is being determined by the distance from the view.

I’ve removed the default Atmospheric Fog actor from the scene and I’ve tried disabling everything else that’s in the scene.
This still happens when I only use direct lighting and it also happens for just a cube-mapped Skylight.

I haven’t baked lighting since it will take too long for this scene and changing parameters in the world settings has no effect.

I’ve tried using a plain material set to Default Lit/Opaque and the same thing happens.

Does anyone know how I can stop this from happening. I’d like the colors to remain the same regardless of view distance.

Hey there!
For testing purposes, it may be good to create a material that is just Green into the base color and assign this to your trees temporarily. If a green only material also change color, the problem would somehow be caused by your scene, lighting, or settings. If this green material does not change colors like your trees, the brown color is coming from your materials.

One suspicion is that the brown is actually your bark color blurring into your green branch when the LODs change. If this is the case, one solution would be to create your own LOD materials/textures that are all tinted to match the green of the branch rather than the brown of the bark.

As you suspected, a straight green material is not changing colors so it would appear that the material is indeed going wonky under LOD.

Thanks for the ideas that help me to proceed with this. I’ll do some reading on how to implement LOD’s properly.

I’m posting a smaller version of the texture that I’m using for the trees and also I took a screenCapture of the UV’s zoomed out.
It’s clear to me now that I did not build the UV’s with far away trees in mind.
It could be that mip-mapping is smearing colors across UV pieces given how close I placed all the islands. Thanks again for your help.
If I’m able to fix this I’ll return here to share how I did it.


Also, you can go to the texture menu and set no mipmaps. If it is a small map, there shouldn’t be a problem. It worked for me.