Why does editor crash on my Chinese system?

Hello,

We are working on a solution to this issue, thank you for your patience.

you mean you find source of this problem ?

@anonymous_user_1da90bc6 and @

Hey guys I had same issue, but I managed to both find what’s causing it and fix it. It might not solve all similar issues but I’m guessing it will help you guys track root issue and fix that so we don’t face it again.

I could go on and give you all kinds of detailed including longs and a half page explanation of my specific issue, but since it’s resolved now I TRY to be brief, though let me know if you still want more info on this.

–Twitter version:

  1. I was able to make editor open again by replacing initial map with a backup version.
  2. underlying problem was caused with an issue that Matinee Actors have, which needs to be fixed.

–Long version:
Yesterday I worked on a test project for a few hours and didn’t experience any issue, regularly saved my work and once done closed editor. I got back to project and saw crash report page, right after selecting project in open project dialog, stating that it is unable ot open my project, I reopened editor a couple times and after a few tries it finally opened so I said it’s fine, considering early stage of editor.

Today however I tried to open project after a computer reset, but it didnt’ want to open at all, after a dozen tries I just gave up and started investigating issue, once I understood that quite some people have exact same problem and it has not been resolved for any of them here, I tries to see if I can find and solve this myself instead of a few days of tracking my posts here. One of first things I did, was check logs in details and I found this:

Attempting to replace an object that hasn’t been fully loaded: InterpFilter /Game/Maps/Example_Map.Example_Map:PersistentLevel.MatineeActor_2.InterpData_0.FilterAll

Which is pointing to a matineeactor I created yesterday. SO next I went ahead and replaced map with a backup version and finally editor opened, what a nice feeling when you can get projects that you worked on days and you though was lost back, lol. No need to say I have lost about an hour of work, so tried to redo them, but this time I closed and reopened editor every 15minutes, to see if issue reproduces. well last reopen it did, finally then I found actual root of issue: matinee actor, has critical problems that need to be fixed, it doesn’t show while you’re working, but once you close editor (in my case twice) it doesn’t like to open anymore.

To be more specific, I created a very very simple matinee that was just moving a platform left and right, that’s it, and THEN duplicated matinee actor once and retargetted it to a new platform mesh. So bottom line, either there is something wrong with duplication process of matinee actor, or with saving of matinee data in map file, either case, map file becomes corrupt and unable to be opened again.

Please fix this issue, and more importantly, map/project should not save in first place if there is an issue that developer needs to fix, becuase at least that way, editor is still open and he can take care of it, not to come back next day and redo his last 2 hours of work plus a lot of frustration. This way, even if other’s similar problem doesn’t have to do anything with matinee, it would take care of most of those too if not all, as I’m assuming at least some of those are facing same root problem in their map files.

Thanks.

Hi ,

Are you installing Github version of editor (with source code) or binary version off of unrealengine.com? Thank you!

You will need Window 7 Service Pack 1 installed in order to run UE4. Can you try installing that and then let us know if it works?

told me i should post my DxDiag here to receive help. I get crashes at start of UE4 100% of times.
can’t enter editor, even after i tryied other solutions link text

Hi ,

We apologize for difficulties you are experiencing, and that we have not yet been able to resolve this issue for you yet.

To help us narrow down issue, please provide following information:

  • Is GTX 550 Ti only graphics card in your system, or do you also have an integrated graphics card?
  • How much Dedicated Memory do you have available for GTX 550? (it says n/a in Dxdiag)
  • Have you updated to latest video card drivers?
  • Can you confirm that your video card is running DX11?

Thank you.

I got source code but i have not compile it yet,u mean i need to compile and see if that version works?

GTX 550 Ti is my only graphics card, i don’t have any integrated graphics card
I got 4096MB = 2GB of Dedicated Memory
My drivers’ version is 8.17.12.9610
I sure i can run directx11 on my video card, cuz i write directx11 graphics program

Hi ,

Please compile code in visual 2013 and let us know if that fixes your problem. I have attached a useful tutorial video for compiling source. Thank you!

http://www…com/watch?v=usjlNHPn-jo&list=&index=24