Download

Why do my Skeletal Meshes float above the floor in Preview Scenes?

In all animation related Preview Scenes (Skeleton, Mesh, Physics) My character floats above the floor, can anyone tell me why this is happening? When the character is placed in the map, it does not float. The root bone and collisions are all at or above 0, but the preview floor is at -10 .

in the scene details you have a value for where the floor should be that you can tweak.

Where is this setting exactly? When I open “Preview Scene Settings” The only control related to the floor is visibility on / off, there aren’t any controls for floor position or height.

Thank you!

is your mesh level in the character blueprint viewport? you sometimes have to move the mesh down the Z axis a bit after setting the mesh.

Yes the bottom of the mesh is level with 0 in the viewport, and I have checked it in other applications outside of Unreal. I noticed the Preview Scenes seem to dynamically align the floor based on the lower (Z min) bounds of the mesh, but sometimes its wrong, like this example.

Ahh…, so in the Viewport ->View Options drop down menu → there is a checkbox for “Auto Align Floor To Mesh” Turning this off puts the floor at 0, as expected. I guess the Auto align is just wonky sometimes.