Download

Why do my mouse + keyboard controls not match the documentation? Completely unable to work

For whatever reason, UE 4.27.2 does not accept input as it should. Running on MacOS, the MacOS specific controls don’t work as specified in Viewport Controls | Unreal Engine Documentation. They also don’t work like they’d do for windows. Instead of “Moves the camera forward and backward and rotates left and right.” left mouse click + drag results in rotating the camera around the focus. Instead of “Rotates the viewport camera.”, right mouse click + drag dollies the camera. The Magic Mouse’s touch functionality does not naturally rotate the camera either, but instead violently throws the focus into an awkward direction at mach 5. Once that happens, I can’t reposition or reorient the camera. Clicking anything + WASD does not allow me to move around. The same problems persist regardless of if I use a Magic Mouse or any other kind of mouse, tried both wired and bluetooth ones. At this point I have tried just about everything besides a blood sacrifice to Baphomet. I am simply unable to work. What could cause this?

Tested the controls on my Mac on your specified version and they seem to be working correctly for me, so your problem may be local. Was this only an issue after you updated?

Fresh clean install of 4.27.2 on a new machine. Happens in existing project and a brand new one. Previously worked on a different MacOS device using same peripherals without any problems.

Alright I’ll see if I can track down a solution for you. In the meantime while I get that started, I know that it’s a fresh install but have you tried the good ol’ traditional uninstall/reinstall?

Yes, unfortunately that did not help. I also tried installing 4.26 just to see if it was an issue with the latest, same thing happened in a blank project. I don’t know if this helps you narrow it down, but the closest to figuring this out I got was finding somebody else’s post with the same problem from ~2016, and they fixed it by turning off and back on their bluetooth…? Few people said it helped them, but I can’t say the same.

Very strange. I’ll let you know if I find anything!

1 Like