Download

Why do my materials stretch?

Hello, first time creating something (newbie). Why are the bricks stretched like that? And how do I fix it? I did a search but couldn’t find anything.

Instead of using stretched blocks use lots of small blocks next to each other the size of the texture you want, or just deal with the stretched textures

Add a texture coordinate node to the bricks texture sample and set the tiling inside that node.
Or UV those particular triangles in a 3d modelling program.

When it’s a static mesh -> create new UV maps in your 3d program
When it’s a BPS -> click on it and in the details panel under alignment you have to set it to planar or something else :slight_smile:

Thanks for the feeback guys. Not using a 3D program right now. @fighter5347, I grabbed a BSP box, selected it, went to Geometry->Alignment->Align Surface Planar (under details) but when I stretched it, it still stretched the material, is that what you meant to do? The best way I came up with for BSP boxes is to go to Geometry Editing, select one side then just drag that side out. It doesn’t stretch it then.

Do the Alignment on the BSP After you’ve got it where you want it.

Grabs BSP box -> puts it out -> stretches it -> clicks box -> details -> geometry -> alignment -> align surface planer -> drags material onto box, material still stretched

Are you using the scale settings to change the size? If you are, you should be using the Brush Settings to change the size of BSP’s. That’s the only reason I can think of that would cause material stretching. Also, try using a material from the starter content, if you’re not already.