Why do my blueprints break when I package my game into a dedicated server?

Hi, I am having an issue with my dedicated server that I’ve had [before][1]. Last time I had an issue like this the issue seemed to fix itself. I have run into it again.

I have 4 elevators which I programmed with blueprints to go in between floors. I have a working setup when I run the game from the editor with the “Run Dedicated Server” option selected under play. When I package the game and sever however, I have issues with the elevators.

My elevators have call buttons on each floor, and when the button is pressed the elevators queue up the floor the button is on if they aren’t already on that floor. If I press the button on the first floor when the elevators are already there when playing in the editor, the elevator just makes a negative beeping sound like it should, indicating the elevator cannot be called because it is already here.

When I do the same thing in the packaged game, I get very strange results. If I press the call button, it seems to effect all of the elevators even though they have no connection in the code, and have no references to each other. If I press the queue button for the first floor while the elevators are already there, the game plays both the “elevator is coming” sound effect and the “error” sound effect. It then queues up all of the other floors and all the elevators take off, leaving the floor they were called to and returning after they have visited every other floor.

In this image, I pressed the elevator button for the elevator on the far right, which sent all of the elevators into motion.
Another thing that is broken is the UI for controlling the elevators from inside.

When I press a button to queue a floor in the editor, everything works perfectly. But when I do this in the packaged game it queues all the elevators to that floor, and displays the wrong information.

The reason I think that this is not an issue with my code is because of the way everything works flawlessly in editor. In editor, one elevator would not control another because everything is very specific, and nothing would be getting a reference to any other elevators. I have checked over my blueprints and cannot find anything that would be allowing or causing this. So I was wondering, does anyone know of anything I could try doing? Any help is appreciated, thank you for your time.

I have also tried rebuilding UE4 and my project, which had no effect.

Ok I fixed it. I uninstalled visual studio, all copies of unreal engine, deleted my project, and moved the file location where I was working. I then reinstalled unreal from source, cloned my project from git, and reinstalled visual studio 2017. I then created a new c++ project, deleted any assets, and copied all the content from my project into this new project. I then manually set all the settings in the new project and compiled. This fixed all of the functionality glitches.