Why do I have a noticable gap in my audio when it loops?

So, I made a really simple soundcue for fire. I made four, five second snippets of a fire. Hooked them up to a random node, then that random node to a looping node, and that node to the output. Everything works as expected, but the only thing that is a miss is that the transitions between the fire loop samples. I have a noticeable gap in the audio each time a new sample is triggered. FYI, they all loop seamlessly in Wwise and in Pro Tools. I am missing something obvious? I tried playing around with some of the parameters, but to no avail. Thanks in advance.


Hello JoeRed82,

I set up a sound cue similar to what you are doing and understand what you are hearing. Firstly change your max concurrent play count to like 32 or something higher than 1. What you are hearing is the “Random” node waits for each sound node to finish playing before choosing another one to play. If your sounds slowly fade, or if they have extra space at the end this is what is happening.

I have set up another way for you to customize your sounds to get rid of the delay so there is always a sound playing being mixed in randomly with the others. This way you have a consistent loop with sounds you have in your cue always playing. This also gives you more control within your Random node to add more weights to sounds you would like to always have playing versus mixing in others as well (which I am assuming you are attempting to achieve with fire).

Random Sounds Using Mixer Node

I hope this helps!

Thanks Andrew, appreciate the answer. I am going to try this out now. Looks promising. Will post back with the results.

You are welcome!

Hi Andrew,

I got essentially the same problem in 4.8.3, even with an extremely simple setups like this:

After each loop there is a noticable gap. If I play the sound from the content browser (loop is set to TRUE) it works as expected without a gap.

I uploaded the sound here:

Hey ,

The documentation has the answer you are looking for within the Sound Cue reference.

Sound Cue Reference


Ah, thank you.

Solution (use the checkbox in the waveplayer):

Maybe this could just be added in the tooltip for the looping node (BTW: Why isn’t the excellent documentation linked from there?)

I can add a feature request to have this changed.

Edit: I have created a feature request, UE-20097, for the suggest tooltip change. Thank you for taking the time to write the report and make the request.


Hi , it sill doesn’t works for me.There is still a gap when looping the audio. Any other solution?

Yeah, it doesn’t work for me as well. I have enabled the “Looping” checkbox on the wav file, and on the sound cue. It still has gap.


Did this issue get fixed, I’m encountering the same issue in 4.18


Did this issue get fixed, I’m encountering the same issue in 4.18

Same issue here :frowning: ! Any alternative solutions ?

Figured it out, go into your sound cue and select the WAV sound linked to the output. Theres a box on the left hand corner that says looping, tick that box, it will loop seamlessly if your sound is mixed and cut correctly :slight_smile:


Issue still persists even in ue5.03. I have checked every looping solution and there is still a noticeable pop in between each loop but it is absolutely seamless in my audio software and the renderer is definitely not adding a .01 sec fade at the end or anything like that.

I even tried using METASOUNDS to combat this and there is still a click/ pop at the end of the loop although it’s noticeably smaller. Does anyone know how to solve this please?

It still doesn’t work. You CAN click “looping” in the WAV-player, then it works, but the WAV-player only allows infinite looping. If you want to use the loop node (because you want to set how many times it loops), it creates a noticable gap. So, this thread/problem isn’t solved at all. It’s almost amusing, how such a simple and basic feature doesn’t work for years.

1 Like

This is true. I can’t remember if I marked it as the solution or someone else did but it’s still an issue…