Why do footstep sound effects play when I jump?


Verify the properties about the sound asset you use. Maybe you have the parameter “looping” checked.

So I’ve set up footstep sound effects in my default run animation. I only have one sound effect that plays at the beginning of the animation and just loops over and over again. For some reason when I jump the footstep sound effect still plays (even if there’s no sound effects in the jump animation). Why does that happen?

I do not have looping checked so what else could it be? Also for some reason the footstep only appears if I put it at the start of the run animation. If I put it at the end or the middle then it doesn’t appear when I jump. Another strange thing is that if I just press the W key once it should only play 1 step sound effect but instead it plays two. What’s going on?

Do you use a blend space asset and a custom anim instance for moving your character or a another way?

I ask this question because i suppose you’re talking about your main character. Personnaly, i made a custom anim with this UE official tutorial 10 - Building the AnimGraph .
The jump managing is present to the middle of the video. Maybe you can pick some ideas from this.

And do I need a model to do this or can I just use the arms that come with the first person layout because for the animation all I use is the arms and the default animations that come with the first person template.

Ah you use first person template…Do you use notify sound in your default run animation ? You can replace this by a custom notify. Next, in anim instance blueprint, you call your custom notify and choose to not playing the sound when the isInAir boolean is true.

Something like that:

run animation:

anim instance blueprint

Where did you get AnimNotify_footstep from? I added the PlaySound notify to my animation and called it footstep.

I did exactly that and nothing appears when I type in footstep in my anim blueprint. What’s going on?

nvm I just figured it out. I had the true false options in the branch backwards so therefore it only plays when I jump.

You cannot reference sound notify from anim instance blueprint.
For creating a custom notify in your animation just:

  • Right click on notifies zone (same as play sound notify)

  • new notify, give a name (footstep by example)

  • go to anim instance blueprint

  • in event graph, right click, type the name of the custom notify… and that’s it.

Oups, i wanted to delete my last post, but it deleted you post too, sorry. if the solution resolves the issue, mark my answer and the thread as resolved