Why did my project suddenly slow down?

Up until a few weeks ago, my project would run completely fine, smoothly like always. But now it makes me wait a couple of minutes between each click, making progress almost impossible. I tried opening other projects, and they ran completely fine. I reinstalled the program, but it didn’t help either. I’m not sure if the project is corrupted. And if it is corrupted, where would the corruption be?

I have the file here: https://drive.google.com/folderview?id=0B2T-LhHsWazLYkNIcklYNmRiRFE&usp=sharing

Thank you for reading, I hope I can figure out what’s wrong soon.

Hello TalkingIsGreat,

Thank you for providing your project as I likely wouldn’t of really known to ask about the correct things without seeing this myself. I got the same results when trying to start PIE, open the Output Log or anything in your project. After looking at the logs though, the issue seems to be inside of BPCharacter’s construction script. The output logs indicated that an infinite loop is being found in the construction script. This causes the editor to freeze for a bit until it realizes and breaks out of it.

The worst news is that this might not be recoverable as far as this particular asset goes unless there are backups old enough in your Saved folder. With that infinite loop there, the editor crashes if you try to open the Blueprint in question. If none of your backups are prior to that infinite loop, I’d suggest removing the blueprint from the project as this will fix the issue.

This is why using source control is always suggested when developing a project. I would suggest looking into using Subversion or Perforce in the future. You may need to piece it together from scratch if you don’t have any backups. Seeing as the loop is in the construction script, opening the blueprint always results in a crash making it impossible to edit it.

Is there any way to copy blueprints over? That blueprint is very vital to the entire project. Am I just going to have to do everything over again?

I opened up the project, deleted the loop in the construction script, saved, restarted the project, and the project worked fine. Thanks for helping me.

I’m surprised to see that you were able to even open the blueprint, as it wasn’t able to do so without crashing for me. I’m glad to see that it’s been fixed though.