Why can't unrealVS plugin seem to find my start up projects?

I was trying to setup visual studio and when I opened the unreal engine 4 project(UE4.sln) I get

All normal. I built it and debugged it as the instructions had said. But, when i went to create a project for the first time i get this

i’ve made a few projects and the unrealVS plugin cant seem to find any start up projects. i have tried re-running the “GenerateProjectFiles.bat” several times. Can anyone help?
UPDATE: Added log file [here][3] :slight_smile:

I have the exact same problem with UE4 4.1. Does anyone know why UnrealVS does not work for a created project when it does work when running UE4.sln? I also get the error LNK1104: Cannot open file …ProjectName.dll and failed to produce item … ProjectName.pbp

Thank you for the info. This sounds like a new bug to me. I’ve added it to our database and I’ll keep this thread updated with developments.

In the meantime, if you could post your UnrealVS logs, I’ll attach them to the bug report. You can find them in [userfolder]\AppData\Local\Epic Games\UnrealVS



Darth: Thank you, but If I look under Options and Settings->UnrealVS–>General Hide Non Game Startup Project it is already set to FALSE.

ChrisWood: I have uploaded the UnrealVS Log file in the attachment. Can this also be the cause for the compiling errors?

link text

link text

I had a similar issue a few weeks ago. Can you check that Options → UnrealVS → General: Hide Non Game Startup Project is FALSE?

It was set to TRUE on my machine and although the solution contained a game project I had an empty UE-Project-Combo-Box like on your screenshots.

UnrealVS won’t be causing build errors. You can disable it in Tools->Extensions and Updates… if you want to confirm that.

@OccultArt - your log says you’re on v1.29. There’s a newer vsix file in the Github master branch if you want to try it.

I have tried the unrealVS that was included with the 4.1 code release. I have even downloaded the most recent code beta release and used the unrealVS from that. First I uninstall the unrealVS plugin, then I Install the new version. But the version number remains 1.29. Should it be a newer version?

My mistake. It looks like the source is on Github but the binaries aren’t included yet.

Here it is…

link text

Thanks, this new (1.30) version works! Problem solved I think.

Answer seems to be v1.30. See link above.

I’m still seeing this issue in 1.3. Is are there some cache files that maybe need to be deleted or something?

Hi kylawl

UnrealVS stores its state in your .suo file. You could try deleting it but it’s unlikely to help. This does appear to still be an issue in v1.30. For now, please use this workaround

If your UnrealVS controls are disabled (even when you have a solution loaded)


Click on the Batch Builder button and it should wake up

I have this issue in 1.44