Why can't the launcher remove 4.21.2?

I recently installed UE4.23.1 and tried to remove version 4.21.2 using the Epic Games Launcher. However I keep getting Error Code: IS-0002-DP-06:" Install Failed/Could not setup permission to install to:C:\Program Files\Epic Games\Ue_4.21".
I can confirm that I have installed UE4.23.1 and now 4.24.0 onto my D; drive as my C; drive is struggling for space.

Does UE4 need to be installed onto C:?
Would I be able to remove all UE4.21 folders? rather than uninstall using the Launcher.

I seem to have a UE4.21 folder under Epic Games folder on D: and under Programme Files on C:


UE4 does not need to be installed on the C: drive.

In my opinion, its perfectly safe to remove the engine manually by deleting its folder. But before that, I’d try running Epic Games as an Administrator and then trying to uninstall the engine, also ensure that no version of UE4 is running as a background process and hampering the uninstall.

Thanks Ian

I logged in as Administrator and got the same result. However I think I’ve got myself into a muddle.
Do I always need to install, update etc through my Administration account as I recently installed UE4.24 through my secondary account.

I noticed when I logged into my Administration account that there are different versions of UE4 in the launcher. Should I uninstall everything UE4 (start from scratch) from both accounts and re-install everything under my Administration account?

Thanks again

OK, I just signed out and back into Administrator and UE4 launcher looked identical to my secondary user account. UE4.21 was successfully removed on this occasion.

Thanks for your help Ian, much appreciated.

You’re welcome! You do not need to be signed in as an Administrator all of the time, but I do recommend committing entirely to one account or another on a single PC. There’s an option when you right click a program called “Run as Administrator” that keeps you from having to log out and back in all the time.