Why can't Movie Render Queue see Niagara FX - UE5.0.1?

Hi.

new to Niagara and have no idea why the particle FX I see in viewport /sequencer are not being picked up my the MRQ…

I retargeted some animations to a metahuman SkeletalMesh and have created a particle effect from someone else’s excellent YouTube video however they don’t touch upon how to get it rendered out with MRQ;) what am i missing in terms of this? any ideas would be much appreciated.

i attach the setup.

thanks in advance for any insights or ideas.





*EDIT

having looked around for a solution to this topic I came across this video that had helped others where control from the sequencer was complained. this included making the Niagara actor spawnable to be able to scrub through them and control the start of the sim [by setting properties for the track in sequencer]. Elsewhere I heard using ‘use attach parent to bound’ for the actor helped also…i have auto activate of for the niagara actor in question. I also increased Bound scale.

but no…no matter what i still have no particles when I render view movie render queue…

can someone please share the ultimate nugget of knowledge and wisdom that allows for particles to be visible to the movie render queue so I can produce some frames;)
seems a very dark secret not documented anywhere by epic or other sources as far as my research has gone.

thanks again

Hi i have same issue, and i solved it

in Render setting > anti aliasing > increase the number at “engine warm up Count” maybe around 64 or try any number

hope it solve your issue @DanH71

4 Likes

I experienced this kind of issue as well. It’s not a bug or engine fault.
To understand this, the sequencer executes the game when the render starts. So, basically, it means the engine will reset everything and starts from frame 1.

It will render your particles based on your particle’s 1st frame location/scale/rotation.

To solve this, just append some frames like 12/24/32/64 extra frames at the beginning. If you start at 0000 then your appended frames will be -0012/-0024/-0032/-0064.

Hope it helps.

1 Like

Yeh thanks to both the above posts suggesting additional frames outside of a beginning frame of 0/1.

But I’d tried that and that didn’t work either.
I did render my particle frames in the end but don’t remember the magic ingredient that got things working.

Not very helpful I know!

Just wish sometimes things were a little better documented since being able to render particles is a pretty big thing so you would have thought critical factors such as this would be well documented.

Maybe it is now but I found very little in terms of generating particles and rendering them via MRQ.

Hi @DanH71 having the exact same problem (And think i also followed the same particle tutorial as you!) - Is there any chance you remember how to get it working? The particles show up fine in editor but in MRQ and also legacy sequencer, the particles do not start. Side note- I am using the life cycle feature on sequencer to control when the niagara system starts and ends.

Hey…

Sorry no exact silver bullet answer.

Think I remember removing lifecycle trigger from sequencer and did add a lot more frames in sequencer before anim start as well as in MRQ I specified a significant amount of warm up frames and upped the temporal antialiasing I believe since it’s (particles) are obviously a time based / accumulative effect.

Hope this helps some way in your further trials.

Hey hopefully by now you’ve figured it out. I was stumped with this problem too but here’s the solution!!! In the render queue be sure to add at least 250 warm up frames via the anti aliasing filter! render and just watch! By frame 35 you should start seeing the particles. Remember particles generate over time so it just takes time to show up in the render! Cheers!

2 Likes

Genius!! Everyone… ignore the solution at the top, it’s out of date and doesn’t work. Use the Antialiasing method!