Download

Why cant I open project after failed migration?

I tried to migrate some assets from one project into another, it didnt happen.

Now trying to open the original project causes a fatal crash, I’m in deep trouble if I cant resolve this.

Does anyone know how to fix this?

Potentially one or more corrupt assets are causing both issues, but it’s hard to tell without crash logs. Start by digging around in (Project Directory)/Saved/Logs.

Thanks for the pointer.

This is what the LogFile is outputting:

[2017.05.27-19.20.40:108] 0]LogCrashTracker:

[2017.05.27-19.20.40:111] 0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2017.05.27-19.20.40:111] 0]LogThreadingWindows:Error: Runnable thread RenderThread 2 crashed.
[2017.05.27-19.20.40:111] 0]LogCrashTracker:

[2017.05.27-19.20.40:111] 0]LogWindows:Error: === Critical error: ===
Assertion failed: (GIsCriticalError || !NumMarks) [File:D:\Build++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Core\Public\Misc\MemStack.h] [Line: 72]

Crash in runnable thread RenderThread 2

[2017.05.27-19.20.40:112] 0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2017.05.27-19.20.40:112] 0]LogWindows:Error: HandleError re-entered.
[2017.05.27-19.20.40:112] 0]LogWindows: FPlatformMisc::RequestExit(1)
[2017.05.27-19.20.40:112] 0]Log file closed, 05/27/17 20:20:40

Any Ideas, whats going wrong guys and is this fixable?

Hmm. Not a whole lot of info there.

Do you recall what assets you were moving around? You could duplicate your project to use as a testbed and try deleting those asset files from the duplicate’s content folder, then try opening its project file and see if you’re still getting a crash. If the crashing stops then one of them is likely the cause. You could potentially narrow down which one by copying the missing assets one by one back into the duplicate project from the original, test running after each addition until the project begins crashing again.

That’s a good idea, I’ll give it a shot, I can send you the complete log file, if you want a look too?

I’ve moved out all the assets I remember migrating, but sadly to no avail, its still crashing.

I’ve found a thread on the answerhub that reccomended deleting the Config, Saved and Intermediate folder, this worked it got everything up and running.

The only problem is the maxwalkspeed and player camera height are way off, I’ve used the level BP to set maxwalkspeed to 50 but it seem to be ignored completely, any ideas on how to fix?

Ahhh. Glad that’s fixed. As for the issues you’re having with the player pawn, it depends how you’re doing it. If, for example, you’re modifying a variable that the pawn’s blueprint is changing itself via some internal logic; you might be setting the walk speed only to have it flipped back to the default value. Edit the blueprint and take a look at how it’s handling movement. Often you’ll see some added variables to handle things like switching between walking and running. If that’s the case, you should be modifying those instead of the max walk speed in the character movement component.

Cheers for that interference, but I’ve tried setting everything I can related to speed in the character bp, it doesn’t seem to be making much difference, so now I’ve got a project that works but is pretty much unusable!

Hmm. Are you sure? Screenshot and post images of the blueprint logic you’re using for movement. There are probably some clues in there; at the very least it’ll help eliminate some possibilities.

Ok sure:
f66cd036c6ba0f9c72a23b59d2115ffe533fefd1.jpegc9d042f7fbcda2f8c87b6c751268b75f5a8809a3.jpeg3.jpg

I’ve tried to mess with the input axis from the project settings but they don’t seem to save.

Additionally, every time I open any map it does a complete build run down for the materials in the map and these don’t for whatever reason stay set an example is the doors (that are white), on start they look grey, then as you turn they change white?!

I think it may be because I’ve deleted the config folder from the game project, but I’d really appreciate some help.

I’ve copied out the defaultInput.ini file from my last working project its set the height correctly, cleared the errors from the mycharacterBP, but I still don’t get the correct character movement.

Message log is throwing out these errors:
eeb7094f178ad4346a7c3f69ba5b4e31c3373ee0.jpeg

Additionally when I insert my original defaultengine.ini file in the config folder it starts to crash, now this refers to the ExampleQ map that started the crashing, is there any way this can be rectified?



[/Script/Engine.CollisionProfile]
+Profiles=(Name="Projectile",CollisionEnabled=QueryOnly,ObjectTypeName="Projectile",CustomResponses=,HelpMessage="Preset for projectiles",bCanModify=True)
+DefaultChannelResponses=(Channel=ECC_GameTraceChannel1,Name="Projectile",DefaultResponse=ECR_Block,bTraceType=False,bStaticObject=False)
+EditProfiles=(Name="Trigger",CustomResponses=((Channel=Projectile, Response=ECR_Ignore)))

[/Script/EngineSettings.GameMapsSettings]
EditorStartupMap=/Game/ExampleQ.ExampleQ
LocalMapOptions=
TransitionMap=
bUseSplitscreen=True
TwoPlayerSplitscreenLayout=Horizontal
ThreePlayerSplitscreenLayout=FavorTop
GameInstanceClass=/Script/Engine.GameInstance
GameDefaultMap=/Game/ExampleQ.ExampleQ
ServerDefaultMap=/Engine/Maps/Entry
GlobalDefaultGameMode=/Game/FirstPersonBP/Blueprints/FirstPersonGameMode.FirstPersonGameMode_C
GlobalDefaultServerGameMode=None



[/Script/Engine.Engine]
+ActiveGameNameRedirects=(OldGameName="TP_FirstPersonBP",NewGameName="/Script/DemProject")
+ActiveGameNameRedirects=(OldGameName="/Script/TP_FirstPersonBP",NewGameName="/Script/DemProject")

[/Script/HardwareTargeting.HardwareTargetingSettings]
TargetedHardwareClass=Desktop
AppliedTargetedHardwareClass=Desktop
DefaultGraphicsPerformance=Maximum
AppliedDefaultGraphicsPerformance=Maximum



I’ve also tried to change the EditorStartupMap and GameDefaultMap in DefaultEngine.ini to a different level in the project but it doesn’t make a difference and just crashes outright?!

Doors: no idea.

Config file: yeah, you probably shouldn’t have deleted that. Just deleting saved and intermediate should have been enough. Virtually everything lost deleting config can be recreated, though. You likely lost project settings, including key mappings and the default game modes and player class. Go into project settings, make sure your INIs are writeable, and ensure those settings are correct.

The errors: they seem to suggest a blueprint script is trying to get the player character and set their max walk speed but isn’t actually finding the player; the “getplayer” function is returning none. Your script doesn’t realise this and attempts to modify “none”'s walk speed, not realising it isn’t accessing the player but, literally, nothing at all. Hence “accessed none.” Is your player pawn being properly spawned and possessed by a player controller? If not, that’s why nothing is registered as the player character. This is either an issue with your settings (see above) or the pawn itself.

I’ve still got the original file and project, but a copy and paste causes a crash.

How do i check this?

To edit project settings, from the main window hit Edit - Project Settings and check the input category for key mappings, general settings for the player base class, and the maps and modes section to make sure you have the right game mode set. As for the player pawn, make sure to check its detail window under the Pawn section and ensure that auto possess is enabled and set to the right player (should be player 0).

Thanks, I’ll give that a shot as soon as I get back home

Thanks for that Interference!

Its a mixed bag of mainly good news the player characters now working as intended and I’ve got the correct player motion.

But my doors that triggered a matinee sequence to open when activated by a trigger volume instead seem to disappear instead of opening.

This is the last problem and once fixed should restore my map (IA hopefully, I think) Any ideas?

Afraid I’ve got no idea what’s causing that. Well, 2 out of 3 isn’t bad, heh. All I can suggest is:

  1. Adding some print strings and break points to your blueprint to see what’s getting run and when. https://docs.unrealengine.com/latest/INT/Engine/Blueprints/UserGuide/Debugging/ should help
  2. Checking the matinee sequence itself to see if it’s doing something weird. Note that Matinee has been replaced with Sequencer in recent builds and you should really be using that instead.