Why can't I get Oneplus One to work with UE4?


We are 3 people working on this game, but I can’t get the game to launch on my phone (OnePlus One)
The launch prosses seems to get stuck on “Deploy Task for launch on A0001…”, but my friends can launch
it on their phones (Iphone6 and Sony Experia Z1 Compact).

The funny thing is the first time I tried to launch a UE4 projekt was with a standard Blueprint
blank scene and it worked. It haven’t worked after that.
I have tried to replicate the same conditions for when it first worked but I haven’t had any luck with that.
Even if my friend did a launch to his Sony phone (with 4.4.4.) that worked and sent that .apk to me, I can’t open it.
The screen just rotates and goes back to normal.

I can launch to a Nexus 7.

My phone is not rooted and has 4.4.4. We are working in UE 4.6.1.

I have the same issue. Can see samsung galaxy s3 in unreal device manager but not my oneplus one

Hi EvilRadish,

Does adb devices recognize your oneplus one?

I have now got mine working after some playing around.
I had to remove my android device from windows device manager, download the latest google drivers and install them again (the drivers I was using were not that old). Not sure what was causing the issue but I am now able to deploy on phone. ADB has worked previously on this machine so phone was fine.